Cannot collect Android APK, even Hello Word, how to fix?

Installed ANT, Android Studio + SDK, NDK In the qt creator there is no possibility to create a virtual device, although the platform is mounted. no platforms for the virtual device selection, so I use real.

Don't know whether these related problems but eventually collect Word Hello does not work
18:23:02: the Process "G:\QT\Tools\mingw530_32\bin\mingw32-make.exe" completed successfully.
18:23:02: Starting: "G:\QT\5.9\android_armv7\bin\androiddeployqt.exe" --input C:/Users/mgkir/Documents/build-untitled-Android_armeabi_v7a_GCC_4_9_Qt_5_9_0-Release/android-libuntitled.so-deployment-settings.json --output C:/Users/mgkir/Documents/build-untitled-Android_armeabi_v7a_GCC_4_9_Qt_5_9_0-Release/android-build --deployment bundled --android-platform android-25 --jdk "C:/Program Files/Java/jdk1.8.0_131" --ant G:/SDK/apache-ant-1.10.1/bin/ant.bat
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Ÿ®L § Be Bibbey ,© . ".
Generating Android Package
 Input file: C:/Users/mgkir/Documents/build-untitled-Android_armeabi_v7a_GCC_4_9_Qt_5_9_0-Release/android-libuntitled.so-deployment-settings.json
 Output directory: C:/Users/mgkir/Documents/build-untitled-Android_armeabi_v7a_GCC_4_9_Qt_5_9_0-Release/android-build/
 Application binary: C:/Users/mgkir/Documents/build-untitled-Android_armeabi_v7a_GCC_4_9_Qt_5_9_0-Release/libuntitled.so
 Android build platform: android-25
 Install to device: No
Buildfile: build.xml does not exist!
Build failed
Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.impl
Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Material.impl
Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Universal.impl
Building the android package failed!
 -- For more information, run this command with --verbose.
18:23:10: the Process "G:\QT\5.9\android_armv7\bin\androiddeployqt.exe" exited with code 14.
Error during Assembly/installation project untitled (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.9.0) )
During execution of step "Build Android APK"
18:23:10: Elapsed time: 00:10.
June 26th 19 at 14:03
3 answers
June 26th 19 at 14:05
So, virtual create did not work, a real no and when to collect?
Live here and collect, besides the build button allows you to simply collect and without the device. - kristian.Denes commented on June 26th 19 at 14:08
That's just the last times he shows real not as a suitable device for some reason. - kristian.Denes commented on June 26th 19 at 14:11
: I think you should try a more stable version 5.9 because I didn't work out. - Tomasa commented on June 26th 19 at 14:14
tried with the same result - kristian.Denes commented on June 26th 19 at 14:17
June 26th 19 at 14:07
Should be spelled out and everything is
settings
b3a304396f024e4286ca2d6662604ef8.png


Then we can think where to send it on a real or virtual device
066a37fa22014212bebc64358f47507f.png - kristian.Denes commented on June 26th 19 at 14:10
in the target api is empty - kristian.Denes commented on June 26th 19 at 14:13
Run the android sdk
I have Lina /sdk/tools/android
and choose what to download, what images, then he should appear - Tomasa commented on June 26th 19 at 14:16
:
C:\Users\mgkir>G:\SDK\sdk\tools\android.bat update sdk
**************************************************************************
The "android" command is deprecated.
For manual SDK, AVD, and project management, please use Android Studio.
For command-line tools, use tools\bin\sdkmanager.bat
and tools\bin\avdmanager.bat
**************************************************************************

android SDK commands can be translated to sdkmanager commands on a best-efforts basis.
(This prompt can be suppressed with the --use-sdk-wrapper commend-line argument
or by setting the environment variable USE_SDK_WRAPPER)
Continue? [y/N]: y
Invoking "G:\SDK\sdk\tools\bin\sdkmanager" --update

Warning: package id Observed 'tools' in inconsistent location 'G:\SDK\sdk\1tools' (Expected 'G:\SDK\sdk\tools')
Warning: package id Observed 'tools' in inconsistent location 'G:\SDK\sdk\1tools' (Expected 'G:\SDK\sdk\tools')
Warning: File C:\Users\mgkir\.android\repositories.cfg could not be loaded.
Warning: An error occurred during installation: Failed to move away or delete existing target file: G:\SDK\sdk\tools
Move it away manually and try again..

C:\Users\mgkir>G:\SDK\sdk\tools\android.bat list avd
**************************************************************************
The "android" command is deprecated.
For manual SDK, AVD, and project management, please use Android Studio.
For command-line tools, use tools\bin\sdkmanager.bat
and tools\bin\avdmanager.bat
**************************************************************************

Invoking "G:\SDK\sdk\tools\bin\avdmanager" list avd

Available Android Virtual Devices:

The following Android Virtual Devices could not be loaded:
 Name: AVD_GalaxyNexus_ToolsForApacheCordova
 Path: C:\Users\mgkir\.android\avd\AVD_GalaxyNexus_ToolsForApacheCordova.avd
 Error: Missing system image for armeabi-v7a AVD_GalaxyNexus_ToolsForApacheCordova.'
- kristian.Denes commented on June 26th 19 at 14:19
June 26th 19 at 14:09
Try Intellige IDEA.

Why offer it:
1. You do not need to separately install the Android SDK (setting the default component is more than 20 GB)
2. You have no problem with the integration of the emulator created by the Android SDK and IDEA.

p.s. started with the Android SDK and IDEA.

Find more questions by tags Apache AntQtQt CreatorC++Android