How to access rails server on Ubuntu on virtual reality and VMware via the Windows browser?

Use Windows 10. On dev VMware installed Ubuntu 14.04. Want to work with RoR project on Windows and the server to keep on Ubuntu. To share the files I have work, and to access localhost-u Ubuntu from a browser on Windows does not work.

  • Ubuntu can ping from the terminal Windows
  • IP Ubuntu prescribed in the hosts file, Windows
June 26th 19 at 14:04
2 answers
June 26th 19 at 14:06
Solution
how have you configured the guest network?
On Windows? There is nothing to set up - jordy_Zemlak73 commented on June 26th 19 at 14:09
: have you ever created a dev with butchoy on the network adapter that indicated? Nat or bridge? - Susanna commented on June 26th 19 at 14:12
: at the beginning of the indicated NAT, then I was prompted to use the bridge. Can reset the screens of the "virtual network editor" in VMware. All the changes I just did there - jordy_Zemlak73 commented on June 26th 19 at 14:15
OK, so what are you listening to the connection with RoR? when I wrote on the gcd is also used VMware like you, in fact I wrote the server responsible for IP Ubuntu on port 3000 - Susanna commented on June 26th 19 at 14:18
: as I understand it, he listens to VMware. At least I more anywhere did not set up - jordy_Zemlak73 commented on June 26th 19 at 14:21
var VM only emulates real PC for OS Ubuntu meets you Ubuntu, you have the project as written? with your server? or what apache should work with the project? - Susanna commented on June 26th 19 at 14:24
with its server. That's the thing: I'm a coder, June front, and I was told to raise RoR of the project (first experience) on the dev ubuntu (first experience) and still do actually what is now in question. Because most of the technical server issues I will not be able to correctly answer, alas :) - jordy_Zemlak73 commented on June 26th 19 at 14:27
: nothing for a long time slowly but will solve your issue :) the main thing is not to despair. As you have in the RoR project has its own server that listens to some port? - Susanna commented on June 26th 19 at 14:30
Yes, that's how - jordy_Zemlak73 commented on June 26th 19 at 14:33
OK, which port is listening in the project? - Susanna commented on June 26th 19 at 14:36
: 3000 - jordy_Zemlak73 commented on June 26th 19 at 14:39
if browser in Windows to turn on ipserver:3000 the browser you say? - Susanna commented on June 26th 19 at 14:42
: 5fb3872a664545cf9dd4bdb40746f943.png
loc.loc is 192.168.88.128 recorded hosts (with ip doesn't work either) - jordy_Zemlak73 commented on June 26th 19 at 14:45
in Ubuntu as root

ufw disable

try to give Ubuntu SP machine from the router - Susanna commented on June 26th 19 at 14:48
: no effect (sudo ufw disable to be after all, right? :D) - jordy_Zemlak73 commented on June 26th 19 at 14:51
Yes :) - Susanna commented on June 26th 19 at 14:54
: how is "give Ubuntu of IP automatic from router" to implement? - jordy_Zemlak73 commented on June 26th 19 at 14:57
: with the standard settings of vmware workstation, in the properties of the new path will put the bridge in network settings in Ubuntu prescribe

auto eth0
iface eth0 inet dhcp

eth0 may be different - Susanna commented on June 26th 19 at 15:00
: you have the opportunity to Skype with share my screen to tell all the steps? I think it would be much easier and faster. Because:
  1. in the network adapter to specify a network connection as a "Bridge"? There are 4 types
  2. can't find where to register the commands in the network settings of Ubuntu
- jordy_Zemlak73 commented on June 26th 19 at 15:03
skinte just screen, Skype is not yet available - Susanna commented on June 26th 19 at 15:06
: No. 1-put a checkmark in the specified location?f30d22da63884a7bb249d6e938a43b32.png - jordy_Zemlak73 commented on June 26th 19 at 15:09
place the bridge, and restart ubuntu. after the reboot, run ifconfig in the console - Susanna commented on June 26th 19 at 15:12
: 89d8380bdc0d472aa9a7992b1e8e0009.png
So - jordy_Zemlak73 commented on June 26th 19 at 15:15
with Windows ping 192.168.214.128 - Susanna commented on June 26th 19 at 15:18
: normally, all pinged - jordy_Zemlak73 commented on June 26th 19 at 15:21
try from a browser 192.168.214.128:3000 - Susanna commented on June 26th 19 at 15:24
: 632fd5b2fe30481ba3109ab92920202a.png - jordy_Zemlak73 commented on June 26th 19 at 15:27
see settings ror - Susanna commented on June 26th 19 at 15:30
: application.yml right?
defaults: &defaults
 static_api_url: "https://static.rewardexpert.com"
 static_images_url: "https://static0.rewardexpert.com/images"
 static_api_user: "reward"
 static_api_password: "FrUBgnRsC8kKtyoaDd64kRxDH"
 REDIS_URL: "redis://localhost:6379/0"
 redis_cache_expire: 86400

development:
 <<: *defaults

test:
 <<: *defaults

staging:
 <<: *defaults

production:
 <<: *defaults
secret_key_base:
 relative_url_root: '/credit_cards'
- jordy_Zemlak73 commented on June 26th 19 at 15:33
: mmm and the config where 3000 is the port written can be seen? - Susanna commented on June 26th 19 at 15:36
: in General, helped here's the command rails s-b 0.0.0.0 :) But thanks anyway for your time) - jordy_Zemlak73 commented on June 26th 19 at 15:39
June 26th 19 at 14:08
Solution
rails s-b 0.0.0.0 solved the problem

Find more questions by tags Ruby on RailsUbuntuVMwareWindowsLinux