How to block a website on OpenSUSE Linux?

Something like parental control. Need to block access to multiple sites via IP on a single computer.
Dig in yast'e, but have not yet found how. What are the opportunities of a firewall to block access to the site in Linux? How is it done?
---
PS I'm not Roskomnadzor and the relations to it are not!
June 26th 19 at 14:15
3 answers
June 26th 19 at 14:17
Solution
I get three dozen options can offer. If by IP, then block iptables'ohms, if the DNS names, then at least in /etc/hosts mount them on 127.0.1.254(really there you just do never listen, never will), though, put the squid and let them/napustite, and it wrap iptables'ohms. Another ip can routit need IP somewhere in space, for example. Specify the task.
is there a website xxx.com want on this PC it does not open. - Manley commented on June 26th 19 at 14:20
In the forehead in the /etc/hosts to prescribe 127.0.1.254 xxx.com
A more reasonable solution, if tomorrow you want something else to filter to discover the squid and transparent proxying, but already there steer. - presley.Mertz70 commented on June 26th 19 at 14:23
: with the squid to not bother hunting for a pair of domains. But thanks for the tip. Probably, the squid is clever in this situation.
But more about space, all the same, tell me.
I in hosts on the IP Yandex sent, and space is like? - Manley commented on June 26th 19 at 14:26
in space is somewhere in 127.0.0.0/8, but not 127.0.0.1, that is the address which you have certainly nothing will not listen to or 240.0.0.0/4, the network is unused and never will not be used. Or even 0.0.0.0 :)

About the squid. You wrote about "parental control", and its counterpart the same squid is the right choice, there has to steer the sheets, add and delete. And with hosts is that for a pair of three addresses where necessary to make quickly. - presley.Mertz70 commented on June 26th 19 at 14:29
So the computer local. It's not a proxy. squid still caches. - Manley commented on June 26th 19 at 14:32
caching can be cut off. Or take a look at privoxy :) - presley.Mertz70 commented on June 26th 19 at 14:35
:
somewhere in 127.0.0.0/8, but not 127.0.0.1

Technically, it is the same, any 127.x.x.x is similar to any other and always "up". So arranged loopback. - Concepcion.Walsh commented on June 26th 19 at 14:38
June 26th 19 at 14:19
Solution
iptables .
or, alternatively, correct the /etc/hosts - wrap name to 127.0.0.1
To turn on the 127.0.0.1 is a bad idea. All instructions for dummies then offer to send some nginx and it will show up when a person wants to put it. Better at some 127.0.1.254, because it's lo /8 and they are all there, and listen to people in there, it won't hang nowhere for him not advise. - Manley commented on June 26th 19 at 14:22
June 26th 19 at 14:21
Solution
Well, the most trivial is to add to /etc/hosts entry 127.0.0.1 domain.com

Find more questions by tags LinuxSUSEFirewall