What is the reason for the lack of ildasm.exe?

Need Ildasm.exe for disassembleable assemblies. Can't find the product in the system. In the directory .NET there is only ilasm.exe for reverse Assemblywoman. I tried to run via cmd from VS - the result is zero, the global search system did not give results too. Perhaps in version .NEt 4.6 of this tool no? but as for me I think it is absurd, because ilasm EXE is present. On the office website information is also not found. MB renamed ? xD
June 27th 19 at 15:12
2 answers
June 27th 19 at 15:14
Solution
What is not an option https://www.jetbrains.com/decompiler/?

"C:\Program Files (x86)\Microsoft SDKs\Windows\v8.1A\bin\NETFX 4.5.1 Tools"\
: Thank you, thank you! But yesterday I finally found what I was looking for=) Although Your option will have in mind. I disasembler from jetbrains seemed pretty decent. - Sean_Rolfs commented on June 27th 19 at 15:17
June 27th 19 at 15:16
Firstly as far as I know this software is included in the kit .NET sdk. The installation of VS is not required. Secondly, I wrote that I tried to run through the terminal developer - finds. Of course you can through the most VS, but that's another story. I am particularly interested in ildasm.exe. - Sean_Rolfs commented on June 27th 19 at 15:19
: Well in the sdk it is included, but the sdk is installed just with the Studio. If it is very distort everything.
Proof:
https://msdn.microsoft.com/ru-ru/library/d9kh6s92(...
https://msdn.microsoft.com/ru-ru/library/496e4ekx(...
So put VS. - Sean_Rolfs commented on June 27th 19 at 15:22
: It's not 1 April=) I Repeat, platform .Net can be installed separately from the environment VS (VS not required). Why .Net is installed along with the installation of VS? Yes, because it is quite logical (Vs the MS product like .Net). Let's say, to avoid unnecessary movements. There is a separate branch from the MS initiates .Net, Xamarin, etc. interesting stuff=)
https://www.microsoft.com/net

And VS I have installed in the system, I wrote that used the terminal developer, and it is part of VS(no .NET). =)
Just can't understand where is my ildasm.exe =) And where can I get it? To be reinstalled .NET? BUT the .NET 4.6 has been integrated into my OS (Probably on update). There is a version 3, but it is disabled. Apparently when installing the OS was originally .NET 3, and after updates were installed the version 4.6. I can't uninstall (for further permutations) .NET by standard means, it is simply integrated. - nicklaus commented on June 27th 19 at 15:25
: .net and that's what you call .net sdk (and in terms of Microsoft
.NET Framework Tools) is two different things. Ildasm is not included in .net and log in
.NET Framework Tools that are installed with VS. A >net can be installed separately.
Specifically why no finds - no idea, the options are many - from simple lack, to poxepeny PATH. Go search in program files/(x86). - Sean_Rolfs commented on June 27th 19 at 15:28
: So You want to say that after downloading .Net Framework by clicking on the reference https://www.microsoft.com/net - I don't get the rich variety of compilers .Net-YAP, BY type ildasm.exe\ilasm.exe ? All this is quite possible to install VS without. And work (if you wish) using the standard editor or a third-party IDE, swiping compile with normal command line and compiler of one or the other .NET-YAP. There booklet from Troelsen, where he tells in detail about life without the medium VS=)
Regarding the search - already was looking for...sense 0=( - nicklaus commented on June 27th 19 at 15:31
: You two links above go? Read what is written there? That .Net TOOLS is installed Wigley?
Once nothing - then re-install. Want framework. But I would advise - viilu. And vnimatelno to see what kind of components it will supply. - Sean_Rolfs commented on June 27th 19 at 15:34
I don't know how to explain=) I wrote above that installation is for obvious many reasons. It is quite logical. But you know what You don't see? The word "only". It is not "only" with VS. Understand?=) It is installed with VS, but not "only" with her=) How people live without VS? Or I've recently reinstalled the OS, was a necessity. I had to compile the file. VS I yet did not put. And lo and behold...all of compilers in the place of the library and of course for Assembling ilasm EXE. But ildasm I have not found. =) - nicklaus commented on June 27th 19 at 15:37
: I'm afraid that you do not understand the difference between .NET Runtime and .NET SDK. It's 2 different things. First you need to run applications .NET and one for their development. The second and the disassembler. Are you sure you have SDK and not the Runtime? - Sean_Rolfs commented on June 27th 19 at 15:40
:
:

https://www.microsoft.com/ru-ru/download/details.a... 4.6.2 dev pack - jennings_Kozey commented on June 27th 19 at 15:43
: Dmitry, what else would you recommend? Any ideas? - Sean_Rolfs commented on June 27th 19 at 15:46
: : All ATP, found the bum=) Wandered not where I expected=) - Sean_Rolfs commented on June 27th 19 at 15:49

Find more questions by tags C#.NET