Why is there a bug in rsync?

Good afternoon. There is a file server which runs a bunch of stuff(on centos), there is a backup server(suse) where once a week, runs rsync to backup Samba, etc.
Today, backup has stopped working, so rsync complains:
NAS:~ # rsync -az --delete root@10.11.4.100:/home/samba/data/ /mnt/Backups/data/ --progress
ssh: connect to host 10.11.4.100 port 22: No route to host
rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]
rsync error: unexplained error (code 255) at io.c(235) [Receiver=3.1.0]

Configuration has not changed, only turned off the NAS.
After 20 minutes everything worked.
Where to look to find out what did not work? I would like to know where did the problem to know what to treat.
July 2nd 19 at 13:30
3 answers
July 2nd 19 at 13:32
Solution
No route to host - no route to the target address.
It is enabled, the route is active, ports open?
The ports were open.
For both servers I connected via putty.
Can glitches switches/DHCP? - Clarabelle_Brown commented on July 2nd 19 at 13:35
July 2nd 19 at 13:34
Solution
Cut down the network or on a file server or on the router to which it is connected.
Anyway when triggered from cron, network was not, rsync didn't know how to run 10.11.4.100

Then, the network was up and it worked and the next time everything went fine.
servers you could connect one but not seen one. - Clarabelle_Brown commented on July 2nd 19 at 13:37
look what was on the router. Maybe there's someone vlan-AMI played at this time. - Clarabelle_Brown commented on July 2nd 19 at 13:40
July 2nd 19 at 13:36
Solution
Perhaps on the server where the backup is changed to mac.On the server from where backup was done was the old Mac in the arp table,so he could not reach the server.

Find more questions by tags CentOSLinuxSUSErsync