What's the catch Acl Cisco does not work?

The rules do not work on real hardware. That is, traffic goes counter not see that the ACL is triggered. Moreover, in the emulator, PT. all works without problems.
The question that can affect which rules do not work? or maybe I do not understand something.
A piece of iron Catalyst 3750X
Most of what is included in the Config. If you need something even more in the config skins.

ip routing
interface Vlan1
description NET1
ip address 192.168.1.4 255.255.255.240
ip access-group NET1_in in
interface Vlan2
description NET2
ip address 192.168.1.18 255.255.255.240
ip access-group NET2_in in

ip access-list extended NET1_in
permit ip 192.168.1.0 0.0.0.15 192.168.1.0 0.0.0.15
permit ip 192.168.1.0 192.168.1.16 0.0.0.15 0.0.0.15
ip access-list extended NET2_in
permit ip 192.168.1.16 192.168.1.16 0.0.0.15 0.0.0.15
192.168.1.16 0.0.0.15 permit ip 192.168.1.0 0.0.0.15

When you ping from 192.168.1.1 to 192.168.1.17 icmp pass but the counter shows that it works. similarly, from 192.168.1.1 to 192.168.1.17
52952b10eec742e180a9b5999c5eb1eb.png
July 2nd 19 at 13:43
1 answer
July 2nd 19 at 13:45
vlan interfaces
interface GigabitEthernet1/0/2
description Link-To-NET1
switchport access vlan 1
switchport mode access
interface GigabitEthernet1/0/3
description Link-To-NET2
switchport access vlan 2

Find more questions by tags Cisco