How to assign dedicated IP for the proxmox virtuallock?

There is a server virtualname on proxmox (debian 8) and the network 88.99.45.112/28

Network configuration on the host machine like this:
auto eth0
iface eth0 inet manual

auto vmbr0
iface vmbr0 inet static
 address 138.201.255.22
 netmask 255.255.255.192
 gateway 138.201.255.1
 bridge_ports eth0
 bridge_stp off
 bridge_fd 0
#Bridge to eth0

auto vmbr1
iface vmbr1 inet static
 address 88.99.45.112
 netmask 255.255.255.240
 bridge_ports none
 bridge_stp off
 bridge_fd 0
#Hetzner subnet /28

auto vmbr2
iface vmbr2 inet static
 address 192.168.8.1
 netmask 255.255.255.0
 bridge_ports none
 bridge_stp off
 bridge_fd 0
#Internal Network 192.168.8.0/24 with DHCP


In virtualcad 2 interface eth0 (to vmbr2), eth1 (for vmbr1).

eth0 inet addr:192.168.8.8 Bcast:192.168.8.255 Mask:255.255.255.0
eth1 inet addr:Bcast 88.99.45.117:88.99.45.127 Mask:255.255.255.240


Routes on VM such:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.8.1 0.0.0.0 UG 0 0 0 eth0
88.99.45.112 0.0.0.0 255.255.255.240 U 0 0 0 eth1
192.168.8.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0


It turns out that VM from outside access by IP 88.99.45.117, but she sees the world in NAT on 192.168.8.0/24 and when requests are lit IP the host machine 138.201.255.22. And need lights IP 88.99.45.117

You need to correct in the network settings or routing?
July 2nd 19 at 16:59
2 answers
July 2nd 19 at 17:01
heck they two seteviki then ? to each other they still will go locally and one bridge
and so it is logical that they are just a gateway to change IP to the first bridge and not the second .
# route add default gw 88.99.45.112
SIOCADDRT: Network is unreachable - ross commented on July 2nd 19 at 17:04
: 112 well, because the IPS cannot be used, use the 113 on the host and hateem in virtualcad
112 the network identifier is obtained for the 240 - Eulalia22 commented on July 2nd 19 at 17:07
July 2nd 19 at 17:03
On virtualcad -
Remove the default gateway 192.168.8.1
Add the default gateway from the network 88.99.45.112/28 - most likely 88.99.45.113

Immediately evident error in the config
address 88.99.45.112 - wrong - you have a network address
88.99.45.113 - most likely the gateway from your ISP and all the rest of 88.99.45.114 for 88.99.45.126 your IPA.

Find more questions by tags ProxmoxKVMComputer networksIP