Logstash stops sending data..?

Put Logstash, kibana . Šµlasticsearch all the fifth version
CentOS Linux release 7.2.1511 (Core)

java-version
java version "1.8.0_73"
Java(TM) SE Runtime Environment (build 1.8.0_73-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode)

CentOS Linux release 7.2.1511 (Core)

/usr/share/logstash/bin/logstash --configtest
INFO: Logstash requires a setting file which is typically located in $LS_HOME/config or /etc/logstash. If you installed Logstash through a package and are starting it manually please specify the location to this settings file by passing in "--path.settings=/path/.."
ERROR: Failed to load settings from file "path.settings". Aborting... path.setting=/usr/share/logstash/config, exception=Errno::ENOENT, message=>No such file or directory - /usr/share/logstash/config/logstash.yml

[root@kibana ~]# /etc/logstash/conf.d/config.conf -f /etc/logstash/conf.d/config.conf --configtest --debug
-bash: /etc/logstash/conf.d/config.conf: Permission denied

/etc/logstash/conf.d/config.conf

input {
udp {

port => 5514
type => "syslog"
}
}
output {
elasticsearch {
hosts => ["localhost:9200"]
sniffing => true
manage_template => false
index => "mikrotik-%{+YYYY.MM.dd}"
document_type => "%{type}"
}
}

[root@kibana ~]# netstat-ntulp | grep 5514
udp6 213440 0 :::5514 :::* 616/java

logstash-plain.log
[2016-11-10T12:40:05,256][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}
[2016-11-10T12:40:05,257][WARN ][logstash.outputs.elasticsearch] Elasticsearch output attempted to sniff for new connections but cannot. No living connections are detected. Pool contains the following current URLs {:url_info=>{}}
[2016-11-10T12:40:08,012][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}
[2016-11-10T12:40:08,013][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>16}
[2016-11-10T12:40:10,259][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}

Data kibano is and then cease to act
July 2nd 19 at 17:54
2 answers
July 2nd 19 at 17:56
192.168.100.253:9200
{
"name" : "UhWJ24N",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "p9iMIEe5TDycADQLjehw5A",
"version" : {
"number" : "5.0.0",
"build_hash" : "253032b",
"build_date" : "2016-10-26T04:37:51.531 Z",
"build_snapshot" : false,
"lucene_version" : "6.2.0"
},
"tagline" : "You Know, for Search"
and curl 127.0.0.1:9200 ? - Arielle15 commented on July 2nd 19 at 17:59
[root@kibana ~]# curl 127.0.0.1:9200
{
"name" : "UhWJ24N",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "p9iMIEe5TDycADQLjehw5A",
"version" : {
"number" : "5.0.0",
"build_hash" : "253032b",
"build_date" : "2016-10-26T04:37:51.531 Z",
"build_snapshot" : false,
"lucene_version" : "6.2.0"
},
"tagline" : "You Know, for Search"
} - tre58 commented on July 2nd 19 at 18:02
Important

Logstash 5.0 introduces a new way to configure application settings for Logstash logstash through a.yml file.

This file is typically located in ${LS_HOME}/config or /etc/logstash when installed via packages. Logstash will not be able to start without this file, so please make sure to pass in --path.settings if you are starting Logstash manually after installing it via a package (RPM, DEB). - tre58 commented on July 2nd 19 at 18:05
and the campaign in the fifth version there is no command configtest - tre58 commented on July 2nd 19 at 18:08
replaced the logstash -t - tre58 commented on July 2nd 19 at 18:11
[root@kibana config]# /usr/share/logstash/bin/logstash -t
Sending Logstash logs to /var/log/logstash which is now configured via log4j2.properties.
Configuration OK - tre58 commented on July 2nd 19 at 18:14
Logs : [2016-11-11T12:58:42,333][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}
[2016-11-11T12:58:42,334][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error_message=>"No Available connections", :class=>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will_retry_in_seconds=>16}
[2016-11-11T12:58:43,479][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}
[2016-11-11T12:58:43,479][WARN ][logstash.outputs.elasticsearch] Elasticsearch output attempted to sniff for new connections but cannot. No living connections are detected. Pool contains the following current URLs {:url_info=>{}}
[2016-11-11T12:58:48,493][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}
[2016-11-11T12:58:48,493][WARN ][logstash.outputs.elasticsearch] Elasticsearch output attempted to sniff for new connections but cannot. No living connections are detected. Pool contains the following current URLs {:url_info=>{}}
[2016-11-11T12:58:53,517][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#}
[2016-11-11T12:58:53,518][WARN ][logstash.outputs.elasticsearch] Elasticsearch output attempted to sniff for new connections but cannot. No living connections are detected. Pool contains the following current URLs {:url_info=>{}}
[2016-11-11T12:58:58,352][WARN ][logstash.outputs.elasticsearch] POOL UNEXPECTED ERROR {:e=>#} - tre58 commented on July 2nd 19 at 18:17
July 2nd 19 at 17:58
output {
 elasticsearch {
 hosts => ["localhost:9200"]
 sniffing => false
 manage_template => false
 index => "mikrotik-%{+YYYY.MM.dd}"
 document_type => "%{type}"
}
}

https://discuss.elastic.co/t/logstash-elasticsearc...

Find more questions by tags Logstash