Why php script does not accept a post request remotely?

Good afternoon, a very simple script from a single line of code print_r($_POST); using various rest clients send him the request contains post parameters, locally it works, when you transfer the script to an external server, it displays an empty array if we are to send POST request with this website script, the script gives a normal response... this behavior started suddenly and at first only some scripts stopped responding to post requests, and is now generally no one responds. Server settings have not changed. That it can be where to dig?087be3f0775742ed81c6d6ddb40a8e45.png
July 2nd 19 at 18:06
3 answers
July 2nd 19 at 18:08
I have approx. Only reason he takes over the POST and GET parameters 45dad2762b454509a48b3db2510914a9.png
yesterday I tried to understand the reasons and instead post bringing the server array, so you have everything in the heap is displayed - marquise24 commented on July 2nd 19 at 18:11
July 2nd 19 at 18:10
I tried to send a post request and using php and from third-party apps, and even with the tablet, everything comes exactly as get it to another domain on the same server coming post - marquise24 commented on July 2nd 19 at 18:13
July 2nd 19 at 18:12
Tried it with one app, here is the result...
e422862b0ce645c591aa152580f7cba2.png
I have such code: https://hsto.org/files/f16/ef9/1af/f16ef91afae042d...
The result:
https://hsto.org/files/9a8/6c8/394/9a86c8394aa04d0... - marquise24 commented on July 2nd 19 at 18:15
Thank you, lost in the wood for the trees... turns out the problem was redirected and you just need to specify the address with the www prefix, otherwise the redirect a post request is converted to get - marquise24 commented on July 2nd 19 at 18:18

Find more questions by tags RESTful APIWeb DevelopmentPHP