Why drops the connection xrdp on OpenSUSE Tumbleweed?

Put xrdp, launched the service. When you try to connect it displays me the login / password window. What Xorg, Xvnc is not running. Starts connecting, then after a while says trying to reconnect, and again displays the login window.
Modified startwm.sh (the problem is that Xorg session was just a black window, and wrote that Xvnc can't connect,because obscure bug). Added startkde command
if [ -r /etc/X11/xdm/Xsession ]; then startkde exit 0 fi

I feel like I saw the beginning of the loading screen session, but then fell. In the logs particularly worthwhile't see anything, the ERROR was one entry where it is shown that the error with the TLS certificate. From what I've read, it cannot be operated under Windows, and it is not particularly critical. In any case, in logs 3 attempts:
  • 16:02 - trying to connect using Xorg
  • 16:05 - trying to connect via Xvnc
  • 16:58 - trying to connect using Xvnc with the configured keys. Error line in the logs disappeared, and the result is the same.
Xrdp-sesman.log
Xrdp.log
June 3rd 19 at 19:19
1 answer
June 3rd 19 at 19:21
Gnome under xrdp is not able to run. Also run and fell. Apparently I was missing some resources from the login dm.
From the black window helped Xwrapper.config allowed_users = any.
do not prompt,where this Xwrapper is? - sim_Schaden49 commented on June 3rd 19 at 19:24
/etc/X11 and check the version of xrdp. In debiane trying to shove junk.And SOR was wrong allowed_users = anybody - Darron.Trembl commented on June 3rd 19 at 19:27
I have OpenSUSE Tumbleweed ), Almost all new. Version as on github latest
SPS, I will look. I would probably be slightly different directory, because not Debian like the axis - sim_Schaden49 commented on June 3rd 19 at 19:30

Find more questions by tags VNCLinuxSUSERDP