Why doesn't scrollOverflow in fullPage?

Here is a function that includes fullPage:
$('.scroll').fullpage({
 anchors: ['first', 'second', 'third', 'fourth', 'fifth', 'sixth'],
 sectionSelector: '.scroll__slide',
 scrollOverflow: true,
 verticalCentered: false
});

So I'm putting the scripts in the footer:
<script src="js/jquery.js"></script>
<script src="js/scrolloverflow.min.js"></script>
<script src="js/jquery.fullpage.js"></script>
<script src="js/libs.min.js"></script>
<script src="js/common.js"></script>

And this error appears in browser console:
fullPage: The option `scrollOverflow:true` requires the file `scrolloverflow.min.js`. Please include it before fullPage.js.

What am I doing wrong?
June 3rd 19 at 20:23
1 answer
June 3rd 19 at 20:25
Solution
I have only one thought, to check availability js/scrolloverflow.min.js - since this campaign file is not loaded
I checked in, opened console in a new window and the code was in place. Maybe it is simply outdated? - moses.Hamm commented on June 3rd 19 at 20:28
you're with the Gita rocked the latest version? it seems the kit is in the folder vendor - Annabel commented on June 3rd 19 at 20:31
I've installed the plugin via bower, and the file scrolloverflow took Gita - moses.Hamm commented on June 3rd 19 at 20:34
on the intranet project? - Annabel commented on June 3rd 19 at 20:37
Yes - moses.Hamm commented on June 3rd 19 at 20:40
, https://github.com/alvarotrigo/fullPage.js
You then took scrolloverflow.min.js? There's even the commentary says: It fixes bugs affecting its integration with fullpage.js - Annabel commented on June 3rd 19 at 20:43
Check another version fullpage.js you and Gita - Annabel commented on June 3rd 19 at 20:46
Again right now, copied the code there and pasted. Nothing has changed. Inserted manually on the new Gita himself fullpage.js and I came up with an error that I need some kind of license key openGL not working the plugin on the page - moses.Hamm commented on June 3rd 19 at 20:49
thanks Gita files from my project, I have everything on the latest version is working fine
try with Gita to use files that are not familiar with bower, it is not clear where he gets the files - Annabel commented on June 3rd 19 at 20:52
Well Yes, the plugin is paid. - Annabel commented on June 3rd 19 at 20:55
And can you write what files you have connected and how? Can I something not so do - moses.Hamm commented on June 3rd 19 at 20:58
I have jquery.min.js 1.12 v, scrolloverflow.min.js and fullpage.js further scripts.js (my js code)
In principle, everything is the same as yours, except libs.min.js - Annabel commented on June 3rd 19 at 21:01
Figured with the plugin... it Turns out I was not the updated version, I updated and all errors are gone. Now I have a new problem. I entered the key that for free projects and plug-in just stopped working not giving any error in browser console. - moses.Hamm commented on June 3rd 19 at 21:04
It is needed simply as an object to create it:
let myFullpage = new fullpage('.scroll', {
 licenseKey: 'OPEN-SOURCE-GPLV3-LICENSE',
 anchors: ['first', 'second', 'third', 'fourth', 'fifth', 'sixth'],
 sectionSelector: '.scroll__slide',
 scrollOverflow: true,
 verticalCentered: false
});
- moses.Hamm commented on June 3rd 19 at 21:07

Find more questions by tags JavaScriptjQueryHTML