Cannot connect to Oracle dB,error ORA — 12154?

Put java,performed ojdbc6.jar(if 14 the error manifest).When connecting via PHP throws an error ORA - 12154.Code in the Studio:
oci_connect('test_user','test_user','jdbc:oracle:thin:@//10.xx.xx.xx:1521/test');
using PHPStorm, all connect fine through ojdbc6.jar.
Database Oracle11g.Need help me.
July 8th 19 at 11:16
2 answers
July 8th 19 at 11:18
And here ojdbc6.jar if you work with Oracle through php?
12154 - not resolvida service name. Check how you are connecting, via via SERVICE_NAME or SID. If you have configured tnsnames.ora.
tnsnames.ora is not in Linux,at least I never found it,I realized that tnsnames this is the string which is registered above: jdbc:oracle:thin:@//10.xx.xx.xx:1521/test .All the data coincide with the data written in the storm.And it connects... - Dallas.Miller7 commented on July 8th 19 at 11:21
: storm is written in java, uses jdbc driver, connection string just specified for the jdbc driver. When you connect from the PHP code it might look different, for example: user/password@10.xx.xx.xx.xx:1521:test - asia_Lesch30 commented on July 8th 19 at 11:24
: I know:)but if you write after the colon does not connect,I have tried it in NetBeans. - Dallas.Miller7 commented on July 8th 19 at 11:27
: PDO not tried to use? - asia_Lesch30 commented on July 8th 19 at 11:30
Tried oci8 ,pdo built it for ,but there further from the truth... - Dallas.Miller7 commented on July 8th 19 at 11:33
Have you ever watched what this error means?

Check the connection string:
Oracle 10g takes the following form: [//]host_name[:port][/service_name].
Starting with Oracle 11g, the syntax is: [//]host_name[:port][/service_name][:server_type][/instance_name] - Donny71 commented on July 8th 19 at 11:36
July 8th 19 at 11:20
Yes, looked at it,it solved the error.The problem was in the syntax
was: jdbc:oracle:thin:@//10.xx.xx.xx:1521/test
should be: //10.17.30.41:1521/m1oper_test

Find more questions by tags OraclePHPUbuntuLinuxJDBC