Why Google Maps API throws an error for all directories except one?

There is a site on the locale (WP, MAMP)

Is the plugin with Google map API.
If the site is located at the address localhost/wp/ , then everything works out of the box, without adding keys, etc.

If the website to be moved to a different directory, such as localhost/mysite/wp or transferred to your hosting, Google API starts to swear on absence of a key and the map turns into a grey block with the word error.
OK, in the console Google, I've created a new project, added a new key, all activated api for maps(just), said code key on the website. But still get the error, card not ale.

Why only in strictly certain directory on local, everything works without any keys?!

What could be the problem? Why adding a key does not solve the problem where Google asks?
July 8th 19 at 11:27
2 answers
July 8th 19 at 11:29
you need to go to the settings API and specify a new path
Tried to register and on the contrary leave blank to accept from any source, the result is not changed. But why it works without the key? - virgie_Ledn commented on July 8th 19 at 11:32
July 8th 19 at 11:31
Managed to solve the problem? I have the same thing only on Beatrix, I do not understand where all this key to take?
failed - virgie_Ledn commented on July 8th 19 at 11:34

Find more questions by tags APIGoogle Maps