What to do and how to treat npm WARN-warnings when installing packages?

Hi Toaster!

Quite rasproboval Gulp. Everything customized, everything works. But while worries(or even not so correctly — is a bit annoying) that when you install all dependencies via npm i throws out a bunch of these warnings:

npm WARN engine css-mqpacker@5.0.1: wanted: {"node":">=5.0.0"} (current: {"node":"4.4.5","npm":"2.15.5"})
npm WARN deprecated cross-spawn-async@2.2.4: cross-spawn no longer requires a build toolchain, use it instead!
npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated lodash@1.0.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0.
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.


Use:

Node: v4.4.5
NPM: v2.15.5

Please tell us how to treat this and what to do to it was gone, not to hide, namely to fix?

Well and that two times not to rise: a bearded, seasoned experienced people, please tell us the difference between sudo npm install and npm install? Why is there ever sudo? What gives? Pitfalls/pros/cons/necessity?
July 8th 19 at 11:45
1 answer
July 8th 19 at 11:47
Solution
0. About npm WARN engine, there is a clear text written request to upgrade the engine node, at least until 5.0.0. Update node.

1. About deprecated - it's not Your problem, it is a problem in the dependencies of the project(accordingly, it is a problem of the developer of the package). You have 2 ways to score, because there is nothing fundamentally wrong with this. To calculate in what package obsolete the addiction, find the package on github/npm to make a pull request with updating dependencies to kick the developer.
See:
stackoverflow.com/questions/35491905/npm-warn-depr...
stackoverflow.com/questions/33974189/npm-warn-depr...
stackoverflow.com/questions/34840153/npm-deprecate...

2. About sudo - authorize the command from your administrator password. Read about sudo. Specifically about npm and sudo, see:
https://github.com/sindresorhus/guides/blob/master...
stackoverflow.com/questions/16151018/npm-throws-er...

Find more questions by tags npm