ERROR: invalid section type common in /etc/Sphinx/sphinx.conf Why?

Prescribed in the sphinx settings section of the common connection of the base of lemmatizer
common
{
 lemmatizer_base = /var/lib/Sphinx/data/dict/
}

when you restart Sphinx throws an error ERROR: invalid section type common in /etc/Sphinx/sphinx.conf

where you want to insert this unit or how to set the dictionaries lemmatizer. The latest version of spninx
July 8th 19 at 12:24
2 answers
July 8th 19 at 12:26
Solution
in the index or indexer prescribed the same block , why comone you have it, what considerations did you make it?
so it was in old enough versions - Garnett_Deckow commented on July 8th 19 at 12:29
: well, it is obvious that if it says not known section Komon it is likely he is old, to be honest as in new I don't know that for a long time a new movie is set up. - Eulalia22 commented on July 8th 19 at 12:32
: well, it's fortune-telling has already begun, the author actually claims that they have the latest version ;) - Garnett_Deckow commented on July 8th 19 at 12:35
: Yes this is the second question the author, and already know that it floats, and not a big fan of documentation, and especially to trust him that he put the last alpha handles is not necessary. - Eulalia22 commented on July 8th 19 at 12:38
Yes, with version cant come out, not the last, but only 2.0.4. But when prescribed lemmatizer_base = /var/lib/Sphinx/data/dict/ index in the block too, when you start cursing on the line. - nikita.Stracke commented on July 8th 19 at 12:41
If post indexer also swears - nikita.Stracke commented on July 8th 19 at 12:44
: this is the version of five years ago probably ))) the very latest. - Eulalia22 commented on July 8th 19 at 12:47
: don't want to read the documentation, check the latest version - Eulalia22 commented on July 8th 19 at 12:50
: put a new version, the problem with the unit disappeared. however the other began, but that's another question. This close down. - nikita.Stracke commented on July 8th 19 at 12:53
July 8th 19 at 12:28
The unit is correct, perhaps the error beyond. Well, the version "latest" is a very vague concept, in some distributions this may be wrong, so I highly recommend to specify.
Upd: remember that before a certain version it was prescribed in the unit indexer

Find more questions by tags Sphinx