How to specify the required version Node.js with the installation?

Make the package, write on TS, compile to es6. To work needed Node.js 6.0.0+.

Is it possible to npm as that specified when installing that the desired version of node 6.0.0+, and STOPAT the installation if the version is lower?
While on mind only comes preinstall script to check for version.
July 8th 19 at 15:58
1 answer
July 8th 19 at 16:00
Solution
You can specify the version of node that your stuff works on:

{ "engines" : { "node" : ">=0.10.3 <0.12" } }

Find more questions by tags npm