How to nertiti NGINX that he understood the GET parameters without the sign "?"?

Hello!
NGINX guru prompt.
Moved the site with Apache where URLS "mysite.com/katalog/kaminnye-topki/&filter=p:31875,64755..." worked, and now doesn't work. but if there is a question mark ("?") defines start parameters, that's all good. ("mysite.com/katalog/kaminnye-topki/?&filter=p:31875,64755..." ).
How to nertiti NGINX that he understood the GET parameters without the sign "?" ?

writing about the need to be sure the question mark is not necessary. I know that. To go into code not want.
I attach the config:
server {
 listen 46.30.42.1:80;
 server_name mysite.ru www.mysite.ru;
 root /home/mysite/web/mysite.ru/public_html;
 index index.php index.html index.htm;
 access_log /var/log/nginx/domains/mysite.EN.log combined;
 access_log /var/log/nginx/domains/mysite.EN.bytes bytes;
 error_log /var/log/nginx/domains/mysite.EN.error.log error;

location / { try_files $uri @opencart; }

location @opencart { rewrite ^/(.+)$ /index.php?_route_=$1 last; }

location ~ /\.ht { deny all; }

location ~* (\.(tpl|ini))$ { deny all; }

if (!-e $request_filename) { rewrite ^/(.*)$ /index.php?_route_=$1 last; }

location /Immortal { index index.php; }
location ~* .(js|css|ico|xml|swf|flv|eot|ttf|woff|pdf|xls|htc)$ {
 add_header Pragma "public";
 add_header Cache-Control "public, must-revalidate, proxy-revalidate";
 access_log off;
 log_not_found off;
 expires 90d;
}

 # Vqmod settings
 # Add trailing slash to */vqmod/install requests.
 rewrite /vqmod/install$ $scheme://$host$uri/ permanent;

 # Run index.php on /vqmod/install calls
 location /vqmod/install/ {
 index index.php;
}

 # Nginx configuration of vqmod htaccess
 location /home/mysite/web/mysite.ru/public_html/vqmod/ {
 location ~ \.(xml|cache) {
 deny all;
}
}
 # End Vqmod settings 

location ~* .(jpg|jpeg|gif|css|png)$ {
access_log off;
expires 10d;
}
location ~ .php$ {
location 127.0.0.1:9001;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
fastcgi_param QUERY_STRING $query_string;
fastcgi_param REQUEST_METHOD $request_method;
fastcgi_param CONTENT_TYPE $content_type;
fastcgi_param CONTENT_LENGTH $content_length;
fastcgi_intercept_errors on;
fastcgi_ignore_client_abort off;
fastcgi_connect_timeout 60;
fastcgi_send_timeout 180;
fastcgi_read_timeout 180;
set by the fastcgi_buffer_size 128k;
fastcgi_buffers directives 4 256k;
fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
}
}
July 8th 19 at 16:09
1 answer
July 8th 19 at 16:11
we definitely need a question mark
Or at least rewrite replacing the & for ? - Daphne_Roob commented on July 8th 19 at 16:14

Find more questions by tags NginxWeb Development