High CPU usage rabbitmq service?

Good time of day. Worried about such things here.

There is a server in google cloud (~ 1vcpu 4Gb ram 20Gb ssd) it has one project (nginx, php, rabbitmq, amqp) and in General for quite some time the cpu load in this instance is not lower than 100%, looking at htop it appears that 75% is the beam/rabbitmq, the actual question is this normal?
While the project is not much visited, and the pages open quickly, the site works, but if you add loads in this use of resources can be a problem, I think. And the rabbit itself so calm in the GUI, without queues and without any apparent load.
Guys say fuck yeah, he loves to eat resources, but what are you going to tell me? The configs on the main website saw that it is fashionable to limit memory (that there is just good), about the cpu, I found nothing.

Need information:
Status of node 'XXX' ...
[{pid,1920},
{running_applications,
 [{rabbitmq_management,"RabbitMQ Management Console","3.5.4"},
 {rabbitmq_web_dispatch,"RabbitMQ Web Dispatcher","3.5.4"},
{webmachine,"webmachine","1.10.3-rmq3.5.4-gite9359c7"},
 {mochiweb,"MochiMedia Web Server","2.7.0-rmq3.5.4-git680dba8"},
 {rabbitmq_management_agent,"RabbitMQ Management Agent","3.5.4"},
{rabbit,"RabbitMQ","3.5.4"},
 {os_mon,"CPO CXC 138 46","2.2.9"},
 {inets,"INETS CXC 138 49","5.9"},
 {amqp_client,"RabbitMQ AMQP Client","3.5.4"},
 {xmerl,"XML parser","1.3.1"},
 {mnesia,"MNESIA CXC 138 12","4.7"},
 {sasl,"SASL CXC 138 11","2.2.1"},
 {stdlib,"ERTS CXC 138 10","1.18.1"},
 {kernel,"ERTS CXC 138 10","2.15.1"}]},
{os,{unix,linux}},
{erlang_version,
 "Erlang R15B01 (erts-5.9.1) [source] [64-bit] [async-threads:64] [kernel-poll:true]\n"},
{memory,
[{total,34621536},
{connection_readers,132568},
{connection_writers,71600},
{connection_channels,131904},
{connection_other,120880},
{queue_procs,234792},
{queue_slave_procs,0},
{plugins,625760},
{other_proc,8794366},
{mnesia,72992},
{mgmt_db,978432},
{msg_index,45856},
{other_ets,1121424},
{binary,21928},
{code,18600771},
{atom,703377},
{other_system,2964886}]},
{alarms,[]},
{listeners,[{clustering,25672,"::"},{amqp,5672,"::"}]},
{vm_memory_high_watermark,0.4},
{vm_memory_limit,1556806041},
{disk_free_limit,50000000},
{disk_free,6428037120},
{file_descriptors,
[{total_limit,924},{total_used,9},{sockets_limit,829},{sockets_used,7}]},
{processes,[{limit,1048576},{used,239}]},
{run_queue,0},
 {uptime,10116559}]


Well, that's common report
rabbitmqctl report | grep -A3 file_descriptors
{file_descriptors,
[{total_limit,924},{total_used,9},{sockets_limit,829},{sockets_used,7}]},
 {processes,[{limit,1048576},{used,239}]},


Thank you all!

UPD: thanks again for the links, I tried to restart upgrade for the rabbit has not solved the problem
erlang version 1:18
rabbitmq-server version 3.6.2-1
while flight normal, day, loading at 10%

UPD2: Was probably a week or slightly more as what began on the new. The new version of rabbit not treated now reboot.
1d1c806f448b4e53a80e75319174ccd9.png
but to go into the process there is no alternative option?
July 8th 19 at 16:22
3 answers
July 8th 19 at 16:24
Well, you can get into the console and Erlang'and see what process eats a lot of CPU time, then draw some conclusions.
July 8th 19 at 16:26
I have also been a few times under windows on a home machine. Happened after resuming from hibernation. RabbitMQ ate a lot of CPU and time consuming. It was treated by reboot. I will say commonplace, but have tried it off and on?
July 8th 19 at 16:28
I think the answer to your question, try stackoverflow.com/questions/25162484/rabbitmq-beam...

Find more questions by tags LinuxWeb DevelopmentRabbitMQPHP