How to fix the openvpn client?

OpenVpn client does not send traffic into the pipe and let directly through the provider. Help to solve the issue. Reinstall the openVPN client gave nothing.
July 8th 19 at 16:44
3 answers
July 8th 19 at 16:46
Solution
The solution was to prescribe
redirect-gateway autolocal
In the client config
July 8th 19 at 16:48
Put the route in the VPN tunnel as the default route.
Either in the config servers, either in your OS.
I need to VPN was routing when I connected to the VPN. Please explain how a string this is done on the server side? - Jana.Glov commented on July 8th 19 at 16:51
route add 0.0.0.0 mask 0.0.0.0 interfaith - earl.Weissnat commented on July 8th 19 at 16:54
Here is the config of the server. There is a line push “route 0.0.0.0 0.0.0.0” that I asked them to add to the given gateway in Windows I could switch the profile "public\private".

Do I need to add route add 0.0.0.0 mask 0.0.0.0 interfaith ?

port 443
proto tcp
dev tun

ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key
dh /etc/openvpn/dh2048.pem
tls-auth /etc/openvpn/ta.key 0
server 10.8.4.0 255.255.255.0
push "redirect-gateway def1"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
push "dhcp-option DNS 10.8.2.0"
push "route-metric 512"
push "route 0.0.0.0 0.0.0.0"
keepalive 10 120
comp-lzo
persist-key
persist-tun
client-cert-not-required
username-as-common-name
duplicate-cn

plugin /etc/openvpn/radiusplugin.so /etc/openvpn/radiusplugin.cnf
log /var/log/openvpn.log
status /var/log/openvpn-status.log
verb 3
sndbuf 0
rcvbuf 0
push "sndbuf 393216"
push "rcvbuf 393216"
cipher AES-256-CBC

In any case, the configuration of the client:

client
dev tun
proto tcp
remote IPSERVICE 443
resolv-retry infinite
tun-mtu 1500
key-direction 1
nobind
persist-key
persist-tun
ns-cert-type server
comp-lzo
verb 3
auth-user-pass "C:\\Program Files (x86)\\OpenVPN\\config\\login.conf"
route-method exe
route-delay 2
cipher AES-256-CBC - Jana.Glov commented on July 8th 19 at 16:57
The solution was to prescribe
redirect-gateway autolocal
In the client config - Jana.Glov commented on July 8th 19 at 17:00
July 8th 19 at 16:50
In the config servers is not written to change the default route , the client has nothing to do with
It is an example of how it's written? My VPN providers is slightly down. - Jana.Glov commented on July 8th 19 at 16:53
Well, the route is assigned by a server can be disabled in the config client if I'm not mistaken.
Besides, you can disable it in the client system.
So the problem is on the client side. - earl.Weissnat commented on July 8th 19 at 16:56
: How to disable on the client side? I want to look settings. - Jana.Glov commented on July 8th 19 at 16:59
: As the client disconnects don't remember, long time did not use OVPN, and the system just add the route. - Jana.Glov commented on July 8th 19 at 17:02
: well, in the standard config of the server it is to look for the default gateway - Jana.Glov commented on July 8th 19 at 17:05
The solution was to prescribe
redirect-gateway autolocal
In the client config - earl.Weissnat commented on July 8th 19 at 17:08

Find more questions by tags System administrationOpenVPN