How to remove error while installing PHP client for retailCRM API work with?

When you install the Libraries for work with API using composer on a VDS server error:
16c7216628ec42588334746ddba86748.png
at the root of the website are only 2 files composer.phar and composer.json
The content composer.json
{
 "name": "retailcrm/api-client-php",
 "description": "a PHP client for retailCRM API",
 "type": "library",
 "keywords": ["API", "retailCRM", "REST"],
 "homepage": "http://www.retailcrm.pro/",
 "license": "MIT",
 "authors": [
{
 "name": "retailCRM",
 "email": "support@retailcrm.pro"
}
],
 "require": {
 "php": ">=5.3.0",
 "ext-curl": "*"
},
 "require-dev": {
 "phpunit/phpunit": "5.2.*",
 "phpunit/php-code-coverage": "3.3.0",
 "phpunit/php-invoker": "1.1.4",
 "phpmd/phpmd": "2.4.*",
 "sebastian/phpcpd": "2.0.*",
 "sebastian/phpdcd": "1.0.*",
 "squizlabs/php_codesniffer": "2.5.*",
 "apigen/apigen": "4.1.*"
},
 "support": {
 "email": "support@retailcrm.pro"
},
 "autoload": {
 "psr-0": { "RetailCrm\\": "lib/" }
},
 "extra": {
 "branch-alias": {
 "dev-master": "3.0.x-dev"
}
},
 "config": {
 "bin-dir": "bin",
 "process-timeout": 600
}
}


What am I doing wrong? (
July 9th 19 at 10:03
3 answers
July 9th 19 at 10:05
White on black is written - need php 5.6 or 7.0, and you 5.5.9.
In the console version and the version on the site (not connected to apache) may differ. - Daphne_Roob commented on July 9th 19 at 10:08
Type which php will see this thing run php, type ls-l /path/to/php (which will be) there will learn binary or a symbolic link to php559 - Daphne_Roob commented on July 9th 19 at 10:11
Please tell me how to install 5.6, the default in apache?
17a6d5709c2c4ceebcc1382deea85925.png - Darron_Yundt commented on July 9th 19 at 10:14
The Ubuntu will not prompt, try searching for "ubuntu install php-5.6":
ubuntuclub.org/bystraia-ustanovka-php-5-6-na-ubunt...
https://webware.biz/?p=2061
freshnotes.ru/obnovlenie-php-5-5-do-php-5-6-v-ubun... - Daphne_Roob commented on July 9th 19 at 10:17
which php is run with /usr/bin/php/, and what to do not very understand... can get more please - Darron_Yundt commented on July 9th 19 at 10:20
: reinstalled, now another error. What is the memory ((
0394feaf6c104143928dda0ae5d0396e.png - Darron_Yundt commented on July 9th 19 at 10:23
: I understand that RAM is not enough and no swap.
Try stopping all unnecessary - the web server, what else is there.
Memory on VPS how much? Swap really? - Daphne_Roob commented on July 9th 19 at 10:26
ps on one of the screenshots above, you site is not blacked out - Daphne_Roob commented on July 9th 19 at 10:29
: Thanks about the site too, I noticed )
106d90cde87c4146bff9a4ae50c006a1.png - Darron_Yundt commented on July 9th 19 at 10:32
Like memory not so little. View top temporarily kill everyone who eats the memory, install the package and reboot, everything should start again. I'm sorry more about the composer can not say anything. - Daphne_Roob commented on July 9th 19 at 10:35
July 9th 19 at 10:07
White on black is written - need php 5.6 or 7.0, and you 5.5.9. :)
Very funny ) But the question is "How to remove error while installing PHP client for retailCRM API work with?" Not why there is a bug. Would help better than to lose. =P - Daphne_Roob commented on July 9th 19 at 10:10
And this is what can be??
0394feaf6c104143928dda0ae5d0396e.png - Daphne_Roob commented on July 9th 19 at 10:13
: Have you tried Google?
https://www.google.com.ua/search?q=php+composer+ca...

stackoverflow.com/questions/18116261/php-composer-... - Darron_Yundt commented on July 9th 19 at 10:16
July 9th 19 at 10:09
The bind to a higher php version 5.6 only require-dev libraries, which are used to test code when you install the library on prod they are not needed, the code of the library depends on curl extension, it will work on 5.3.

So this problem can be eliminated by running composer with --no-dev:

composer install --no-dev

Find more questions by tags ComposerAPI