How to restore mbr on asus 701 via a flash card?

Available asus eeePC 701. At boot gives "missing operation system", in this case, regardless of where it is proposed to boot from the flash drive or hard. Change boot priority in BIOS did not help. Try to load Partition Magic from a flash drive whose image has been downloaded UNetBootin - also were unsuccessful. Ie the main problem that does not boot from the flash drive at all.

I suspect that by mistake demolished the mbr and try to restore it, but it is unclear how this is related to the failure to boot from flash media. Tried to put it on different distros using the above utility error is the same.

The last time the system booted from the flash drive, in the process act manual relabeling include partitions fdisk-l gave two partitions sdb and hdc at the same time they differed in size by only a few hundred bytes, although the netbook is only one hard disk. The decision was made to change the markup sdb and reformat under Linux, and then attempted to install the Damn Smal Linux on sdb, which in turn was not successful and the result was something I'm trying to understand now.

What could be the problem? What are the ideas, what materials you can ask for a decision?

In advance very grateful for the answers.
July 9th 19 at 10:17
1 answer
July 9th 19 at 10:19
Solution
The problem turned out to be quite banal, but nevertheless sufficient to take away a couple of hours.

fdisk-l /dev/<emailalert>
showed that the card is not marked as bootable (boot)
This flag is changed option "a" in the utility.
The problem is solved.

Find more questions by tags ASUSLinuxMBROperating systems