How to make a working dhcp server?

Hello!

This question is the N-th number of points Ubiquti. Customers now receive addresses from the main DHCP server (on windows server, the role of the border router acts as a machine with routeros). There was a need to distribute wifi. Did the following:

In the controller settings of the access points have created an additional network with vlan 300 (for example).
On routeros on the interface looking in a local network, created a new vlan interface (also 300) and hang it on the dhcp server.

The problem is that clients do not receive addresses. Prompt where to dig and how to diagnose where the problem is?

RouterOS

/interface vlan
add interface=ether3-local name=vlan-3-wifiguest vlan-id=300

/ip pool
add name=dhcp_pool1 ranges=192.168.3.100-192.168.3.254

/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool1 disabled=no interface=\
vlan-3-wifiguest lease-time=8h10m name=dhcp1

/ip address
add address=192.168.3.1/24 interface=vlan-3-wifiguest network=192.168.3.0
July 9th 19 at 10:19
1 answer
July 9th 19 at 10:21
Thank you all! Problem found, as is always the case of inattention, the vlan settings in the wifi settings network does not put one toe. (30 instead of 300)

Find more questions by tags MikrotikUbiquitiUniFi