Is it worth to install the most recent version of modx when studying?

I'm always worried about the latest version of CMS and other types of engines that have the possibility of expanding the functionality of third party modules and add-ons. Is installs the latest version, and plug-ins (or anything else) is not compatible.
Now the latest version is 2.5.0, and I can't decide whether to put it or take better 2.3.3 which I think will be fewer problems (guided by the number of downloads).

Before with modx has never worked, and maybe my question is not quite correct.

In General, prompt please with a choice.
July 9th 19 at 10:30
1 answer
July 9th 19 at 10:32
Solution
Basic differences for you. Put the last.

Find more questions by tags MODX