How to disable/increase the limit of SMS sent via the android app?

There is a android app. Installed on machine: fly iq434 (android 4.2.2, kernel version 3.4.39). On the unit is KingRoot.
Periodically, when the SMS exceeds a certain limit set in android settings, I get the message:
App is sending a large number of SMS messages. Do you want to allow this app to continue sending messages?


Tried that - does not help:
2. Type in adb shell hit enter
3. Type in su hit enter
4. Type in sqlite3 /data/data/com.android.providers.settings/databases/settings.db hit enter
5. Type in INSERT INTO secure (name, value) VALUES('sms_outgoing_check_max_count’, 9999); hit enter
6. Type in INSERT INTO system (name, value) VALUES('sms_outgoing_check_max_count’, 9999); hit enter
7. Type in .exit hit enter (you should now see a hash tag again instead of sqlite>. If not conitune typing in .exit and hitting enter until you are)
8. Type in sqlite3 /data/data/com.google.android.gsf/databases/gservices.db
9. Type in INSERT INTO main (name, value) VALUES('sms_outgoing_check_max_count’, 9999); hit enter
10. Again exit back to where the command line has a hashtag
11. Type in reboot and hit enter.


Installed app: sms limit unlock - does not help.

Google didn't find anything else, except for these two solutions.
Help, don't know what to do.

There must be another solution to the problem.

I think it is possible, some way to catch this warning and to emulate pressing "Allow" - but don't know how to do it.
July 9th 19 at 12:49
1 answer
July 9th 19 at 12:51
Also this problem.
Now only 1 option found:
1. Install teamviewer
2. Connect with a smartphone(remote desktop)
3. Set the clicker and click in a certain part of the screen when you see the message
Solved this problem by putting android 2.3 - this version has no restrictions. - Delilah42 commented on July 9th 19 at 12:54

Find more questions by tags Android