How to run jar from Intelij IDEA on Ubuntu 14.04?

In General, File > Project Structure > + > jar with depedencies > choose rnn.BasicRNNExample > OK > OK.
Then Build > Build Artifacts > Build.
Everything seems to compile, but...
Open terminal, the following dialogue with him:
$ cd ~/Desktop/NNF/classes/artifacts/JForex_SDK_jar/
$ ls
JForex-SDK.jar
$ chmod +x JForex-SDK.jar 
$ java JForex*
Error: Could not find or load main class JForex-SDK.jar
$ java-jar JForex*
Error: Invalid or corrupt jarfile JForex-SDK.jar
$ ????????
????????: command not found
# rm-rf --no-preserve-root /

Okay, open as archive, see the META-INF folder, in it we see the MANIFEST.MF. Open. Contains the following:
"Manifest-Version: 1.0
Main-Class: rnn.BasicRNNExample

"

Help to launch the project and explain the error.
July 9th 19 at 12:49
3 answers
July 9th 19 at 12:51
Solution
In General, this is a bug in Intellij IDEA itself, because it was compiled in Eclipse and all runs (Export => Runnable JAR file => ... => PROFIT!!). Recommend to develop and test in IDEA, but to compile in Eclipse. On taste and color, you can of course choose Eclipse, but IDEA I prefer.
July 9th 19 at 12:53
Start jar need:
java-jar NameOfYourOwesomeProgramm.jar

More information about the options can be found with the command
man java
Sorry, but I've done it before, there is a bug
Error: Invalid or corrupt jarfile JForex-SDK.jar - samanta_Ho commented on July 9th 19 at 12:56
: You have some trouble with the MANIFEST file.MF inside the jar file, or rather not say - asia_Lesch30 commented on July 9th 19 at 12:59
: I'm more of segod inclined to think that this is a bug IDEA, because well damn, why I chose Ubuntu and Java if the bugs more than the usual pancake windose. - samanta_Ho commented on July 9th 19 at 13:02
What's the Idea, if you have a terminal jarnik start does not work? You straight error reads: "invalid or corrupt jar file", and you begin to say that this is a problem, Idea or Ubuntu. The probability that this is a problem in axis or Java-machine is infinitesimal compared to the likelihood that you jarnik broken. - carrie commented on July 9th 19 at 13:05
: how the hell am I decompiling NOT broken jarnik? I'm doing everything like in documentation, even in stack******** just write the foreign language users - samanta_Ho commented on July 9th 19 at 13:08
Jar file already contains the compiled code in the form .class files, so jarnicki are not compiled, they are run. java-jar application.jar - carrie commented on July 9th 19 at 13:11
You understand. Maybe I should just try to compile in another IDE? - samanta_Ho commented on July 9th 19 at 13:14
July 9th 19 at 12:55
There may be a problem with the Java. Maybe you collected a Jar file under one java version and OS is another. This problem
No, there is only one version of java "1.7.0_101"
OpenJDK Runtime Environment (IcedTea 2.6.6) (7u101-2.6.6-0ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode) - samanta_Ho commented on July 9th 19 at 12:58
and for InteliJ Idea what Java is installed? The same? - asia_Lesch30 commented on July 9th 19 at 13:01
Yes, there was looking for, than it compiles - samanta_Ho commented on July 9th 19 at 13:04

Find more questions by tags IntelliJ IDEAJavaUbuntu