Problem with touchpad after updating linux kernal version 4.*. What do not know?

Install laptop Linux Mint 17.3. Out of the box there is a linux kernel 3.19. But on the laptop the touchpad doesn't work at all. Solved it by installing a new kernel.
Put a 4.5 Yes 4.6 or even higher than 4 then that happens.
A little podlagivaet GUI and still the screen flickers especially when the mouse driver. What I do not SNAU.
No discrete vidyuhi. Only Intel Hd Graphics 520.
Trying to put the firewood there but climbs a lot of dependencies. Maybe someone knows how to solve the problem?
July 9th 19 at 12:56
2 answers
July 9th 19 at 12:58
Solution
I have problems with the touchpad broken after installing Ubuntu it was solved by adding "i8042.nomux=1 i8042.noloop=1" to /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux=1 i8042.noloop=1"
Then sudo update-grub and restart
It did not help. But thanks for the help. Okay, then I will work while so. MB 18 version piixide. - Nicklaus39 commented on July 9th 19 at 13:01
July 9th 19 at 13:00
Hi, also have problems with touchpad on mint 17.2/ From the outlet if netnic to feed everyone like normal. Also recently installing Nvidia produced. Maybe because of this.
But I have no discrette and why is it after upgrading the kernel the touchpad works. Couldn't you just refresh the wood? - Nicklaus39 commented on July 9th 19 at 13:03
: This is a problem in the Assembly itself. On other versions do not watch this. The normal flight. - Nicklaus39 commented on July 9th 19 at 13:06

Find more questions by tags LinuxMint