Mikrotik Hotspot: whether it is possible on the fly, without breaking the session (re-login), change the ceiling rate of a particular user using scripts?

The hotspot when user login adds to the shaper rule, but it is dynamic and api and/or the console does not edit it, only remove (OO)
Don't know why this sticks in wheels put developed, but I hope that this can be done while you think about cloning parameters in a new static rule and the removal of old, well or score, but it's all for a specific purpose not intended=)
July 9th 19 at 13:06
2 answers
July 9th 19 at 13:08
Solution
So, found a relatively easy solution how to control the speed of the user the hotspot on the fly, without the need to re-login.
In General, as I suspected, no one bothers to clone a rule Simple Queue that is automatically created by the hotspot, with the new desired values for a specific ip and place it top of the list and need to edit scripts. And the rules from Hotspot to be placed in the bottom of the list, in the user profile tab in the Queue to put the Insert Queue Before = bottom.
When you need to set different characteristics of the shaping for the user clone the rule and put it up, for example:
/queue simple add copy-from=[/queue simple find target="192.168.100.253/32"] name="boost-192.168.100.253" place-before=0

As the name must be unique, duplicates will not, if re-trigger.
It can be created automatically when user login, writing the script On the Scripts tab of the Login profile
/queue simple add copy-from=[/queue simple find target="$address/32"] name="boost-$address" place-before=0
but it is better out of necessity. Native to remove, in principle, it makes no sense.
On Logout is required for a clean up:
/queue simple remove [/queue simple find target="$address/32" dynamic="false"]

That's all...
July 9th 19 at 13:10
Adjust the shaper and you will be happy...! Start to excavate it by selecting "Queues"
Um... Yes what here happiness Queues in dynamic rules does not allow to edit. accordingly, to set nothing=) - Betsy.Krajcik92 commented on July 9th 19 at 13:13
: "... dynamic rules in Queues does not allow to edit." do not quite understand the remark... - eleanore.McCullough commented on July 9th 19 at 13:16
: nekroticeskih Hotspot when login user, if it not only is unlimited, and it creates a dynamic rule in the Simple shaper Queues on the IP. The user logged in rule is created, left - left. It would seem to fix the limit on the rule, using a script that may be easier, but alas, dynamic rules cannot be edited, only deleted. That's where the trouble... - Betsy.Krajcik92 commented on July 9th 19 at 13:19
: ?!?! I have a Microtik house and somehow I did not see him "evil"! (unless of course on the stage setting was not involved the option "enable dummy rules")... When you reset to factory defaults Microtik section Simple Queue remains pristine as the first day after the creation of the world! Regardless of the number of connected users...
And I can assert with a probability of 99.5 percent, because it is tested on three different pieces of iron Microtik (home and 2 at work...)! - eleanore.McCullough commented on July 9th 19 at 13:22
: UPD: sorry, not noticed that we are talking about the HotSpot...
Then pick a custom profile.
it-nik.com/articles/nastraivaem-hotspot-na-mikrotik
I think that the changes will only work for new connections... - eleanore.McCullough commented on July 9th 19 at 13:25
: the way it is... only for new sessions, and then sad, "turbo mode" just don't realize=). Generally developers do not understand why it was done. The only hope is to delete the rule and create on the same ip its rule in the onLogin/onLogout, but it is not clear how to sync this thing, so as not to clog up the queue rules, when the user makes logout. In General, I find myself a pain in the ass :D - Betsy.Krajcik92 commented on July 9th 19 at 13:28
: "Monsieur knows his perversions..." :) - eleanore.McCullough commented on July 9th 19 at 13:31

Find more questions by tags Network equipmentMikrotik