How to change Digest username in freepbx?

There is a trunk

type=peer
host=example.local
port=5060
fromuser=sip1
secret=pass
fromdomain=example1.local
insecure=port,invite
context=default
allow=all
nat=yes
qualify=yes


With shirokoi registration:

sip1@example1.local:pass@example.local

There is also a line in sip_registrations_custom.conf

auth=sip2:pass@BroadWorks

Registration no.

From the other side saying that:

Authorization: Digest username="sip1", realm="BroadWorks", algorithm=MD5, uri="sip:example.local", nonce="BroadWorksXiobe3c3bTs6cwotBW", response="d9c9f97847975469107168ddf4cb3a23", qop=auth, cnonce="3175286b", nc=00000001
Expires: 120
Contact: <sip:s@213.30.202.169:5060>
Content-Length: 0</sip:s@213.30.202.169:5060>


"In highlighted in red should be instead of sip2 sip1
Unfortunately the settings of FREEPBX, I will not prompt where it is to rule."

In other words - how to explicitly specify Digest username?
July 9th 19 at 13:38
1 answer
July 9th 19 at 13:40
Sam asked, he replied:

cat sip.conf
......
[authentication]
auth=sip2@BroadWorks

Find more questions by tags FreePBXLinux