Why not find gulp (do not put globally)?

Good afternoon everyone.
Moved to a new working machine, it is the captain 10.11.3
Put node, npm, gulp globally next, upload your project, do npm isee that everything tightens. Next, gulp -v and see -bash: gulp: command not found

I found a solution with the addition of the following:

"scripts": {
 "gulp": "gulp",
 "minify": "gulp minify"
 },


and can be run via npm run gulp, but still.

Who faced a problem? How did you decide on?

Console, install gulp
FS-MacBook-Air:lib FS$ sudo npm install gulp -g
Password:
npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v6.0. Please update to graceful-fs@^4.0.0 as soon as possible.
npm WARN deprecated lodash@1.0.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^4.0.0.
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v6.0. Please update to graceful-fs@^4.0.0 as soon as possible.
/Users/FS/.npm-global/bin/gulp -> /Users/FS/.npm-global/lib/node_modules/gulp/bin/gulp.js
gulp@3.9.1 /Users/FS/.npm-global/lib/node_modules/gulp
├── interpret@1.0.0
├── pretty-hrtime@1.0.2
├── deprecated@0.0.1
├── archy@1.0.0
├── minimist@1.2.0
├── tildify@1.2.0 (os-homedir@1.0.1)
├── semver@4.3.6
├── v8flags@2.0.11 (user-home@1.1.1)
├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, strip-ansi@3.0.1, has-ansi@2.0.0)
├── orchestrator@0.3.7 (stream-consume@0.1.0, sequencify@0.0.7, end-of-stream@0.1.5)
├── liftoff@2.2.1 (extend@2.0.1, rechoir@0.6.2, flagged-respawn@0.3.2, findup-sync@0.3.0, resolve@1.1.7)
├── vinyl-fs@0.3.14 (graceful-fs@3.0.8, strip-bom@1.0.0, vinyl@0.4.6, defaults@1.0.3, mkdirp@0.5.1, through2@0.6.5, glob-stream@3.1.18, glob-watcher@0.0.6)
└── gulp-util@3.0.7 (array-differ@1.0.0, array-uniq@1.0.2, lodash._reinterpolate@3.0.0, object-assign@3.0.0, lodash._reescape@3.0.0, beeper@1.1.0, lodash._reevaluate@3.0.0, replace-ext@0.0.1, has-gulplog@0.1.0, fancy-log@1.2.0, vinyl@0.5.3, lodash.template@3.6.2, gulplog@1.0.0, through2@2.0.1, multipipe@0.1.2, dateformat@1.0.12)
July 12th 19 at 17:04
1 answer
July 12th 19 at 17:06
Solution
the problem with npm, the solution was sudo chown-R $(whoami) ~/.npm

stackoverflow.com/questions/16151018/npm-throws-er...

Find more questions by tags Gulp.jsNode.jsnpm