Wordpress — all pages except the home shown on the template 404.php. How to fix?

Hello.
I now pull the layout into Wordpress locally on OpenServer. Suddenly all pages except the home began to appear on the template 404.php. I attribute this to the fact that in the process changed the url settings - I never changed them on the CNC and when I did, apparently the problem occurred. I googled in the Internet that offer to solve the issue by changing the contents of the file .htaccess and enabled mod_rewrite configuration, Apache server.
Just change .htaccess did not help.
In Apache, the line "LoadModule rewrite_module modules/mod_rewrite.so" uncommented, and
AllowOverride All
...

Content .htaccess is now:
# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Prompt, I correctly understand your problem with the pages, if I do what is necessary, and how to deal with the problem? Hosting is not yet filled, because to fully understand what's going on here.
Thanks in advance.
July 12th 19 at 17:06
4 answers
July 12th 19 at 17:08
Re-register the NC
it did not help.
probyval on the pages themselves. and in settings -> permalinks - Orlo.Emmeri commented on July 12th 19 at 17:11
July 12th 19 at 17:10
Initially in the settings of permalinks were "simple" .../?p=123, then I changed to "record name" .../sample-post/, and there was a 404 error. Now tried to return to the "simple" and all perfectly displayed as before. And for pages he does not like any setting other than .../?the primary objective of BCC=34.
But I still wish for greater clarity to display the title of the page/post.
Index.php present.
Simple re-saving of link is not helping.
July 12th 19 at 17:12
this is the standard htacces wordpress.
# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress


What you have in settings "Settings > permalinks" in the admin? In the template file is present index.php ?
July 12th 19 at 17:14
"<"Directory path to project>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
"<"/Directory">"

Add to apache2.conf

Find more questions by tags ApacheWordPressOpen Server