Why I can't create a COM class object?

Good day!

There's such comrades. They have a client for your system. The client API via com. Put the client. Check in the registry, the class was https://yadi.sk/i/KHyURBwJghua3 . Through the service components all components pertaining to a customer add a user with the right to work with the given object. But when I run a simple test script:

var_dump(com_load_typelib('EApi.Head'));
try
{
 $obj = new COM("eapi.head");
}
catch(Exception $e)
{
 echo $e->getMessage();
}


either

dim oHead
set oHead=CreateObject("EAPI.Head")


the result is always the same: the class is not registered in the system. Tried to manually install a dll:
regsvr32 /i Eapi.dll
in this case, the error about invalid entry point https://yadi.sk/i/yfHyqUVsghxH8 . This set of action were tried as a simple user and admin. On the server and your local machine. Launched from under Apache and from the console. What else can I try?

System winsrv2008, win7, both x64

I would be grateful for any help!
August 15th 19 at 17:58
1 answer
August 15th 19 at 18:00
Take a look here, maybe will help.
stackoverflow.com/questions/4897685/how-do-i-regis...
How to jump with a tambourine around such problems, but honestly do not remember what was decided...
Nope, the solution had hands to register in the system. Helped me an article from 1C kb.mista.ru/article.php?id=870 - Lourdes commented on August 15th 19 at 18:03

Find more questions by tags Component Object ModelWindows ServerAPIPHP