Do not load the styles of the website on wordpress (404 error)?

Wordpress just started to learn...

In developer mode in Google chrome next to the file styles indicate the status 404.

header.php:

<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" <?php language_attributes(); ?>> <![endif]-->
<!--[if IE 7]> <html class="no-js lt-ie9 lt-ie8" <?php language_attributes(); ?>> <![endif]-->
<!--[if IE 8]> <html class="no-js lt-ie9" <?php language_attributes(); ?>> <![endif]-->
<!--[if gt IE 8]><!--> > <!--<![endif]-->

 <meta charset="<?php bloginfo( 'charset' ); ?>">
 <title><?php wp_title('|', true, 'right'); bloginfo('name'); ?></title>
 <?php wp_head(); ?>

>

 <header class="top_header">
 <div class="wrapper">
test
</div>
</header>
 <section class="home_slider">

 </section>


Part of front.php
/**
 * Enqueue Theme Styles
*/
ale_enqueue_styles function() {

 // add general css file
 wp_register_style( 'aletheme_general_css', THEME_URL . '/css/general.css', array(), ALETHEME_THEME_VERSION, 'all');
 wp_register_style( 'jquery.jscrollpane', THEME_URL . '/css/jquery.jscrollpane.css', array(), ALETHEME_THEME_VERSION, 'all');
 wp_register_style( 'jquery.fancybox-1.3.4', THEME_URL . '/css/jquery.fancybox-1.3.4.css', array(), ALETHEME_THEME_VERSION, 'all');
 wp_register_style( 'aletheme_fontawesowe', THEME_URL . '/css/font-awesowe.min.css', array(), ALETHEME_THEME_VERSION, 'all');
wp_enqueue_style('aletheme_general_css');
wp_enqueue_style('aletheme_fontawesowe');

}
add_action( 'wp_enqueue_scripts', 'ale_enqueue_styles' );


Doing all the lessons, mistakes, like, not allowed, but... what's the problem?
August 19th 19 at 23:06
1 answer
August 19th 19 at 23:08
Solution
check the path constants THEME_URL, 404 means that the specified path file not found
The path is correct - Madisyn99 commented on August 19th 19 at 23:11
:
In developer mode in Google chrome next to the file styles indicate the status 404.

So some styles it's trying to load, just 404 so he finds them there, then the way it true


Of course another possible option, the access rights to these files or directories, but it seems unlikely.


the third option can not be - Madalyn_Ha commented on August 19th 19 at 23:14
Copied the entire lesson and everything is normal open, then copied the piece of code from front.php and paste it into your — problem solved, though the path was correct, sort of. Unlike the finished version and mine was that I connected (or indicate they do not know how) 4 file and output 2 (wp_enqueue_style) when ready connect only 2 (general.css and font-awesowe.min.css). Maybe that was a mistake? - Madisyn99 commented on August 19th 19 at 23:17
: no, the mistake was incorrectly specified paths - Madalyn_Ha commented on August 19th 19 at 23:20
:
ale_enqueue_styles function() {

 // add general css file
 wp_register_style( 'aletheme_general_css', THEME_URL . '/css/general.css', array(), ALETHEME_THEME_VERSION, 'all');
 wp_register_style( 'aletheme_fontawesome', THEME_URL . '/css/font-awesome.min.css', array(), ALETHEME_THEME_VERSION, 'all');

wp_enqueue_style('aletheme_general_css');
wp_enqueue_style('aletheme_fontawesome');
}
add_action( 'wp_enqueue_scripts', 'ale_enqueue_styles' );


Your code was replaced with this - Madisyn99 commented on August 19th 19 at 23:23
all understand... the letters w and m confused :D - Madisyn99 commented on August 19th 19 at 23:26

Find more questions by tags WordPress