Presumably after upgrading to Windows 10 is partially not working Chrome. How to fix it?

Since yesterday Google Chrome (56.0.2924.76) on Windows 10 (OS Build 14393.693) right to download part of the site.

All sites are Google (search, youtube etc) are opened immediately. Geektimes and Habr already worse. Some work sites do not open at all. Part requests hangs as "pending", part loaded with an incredibly low speed, part of it disappears with the error "Failed to load resource: net::ERR_CONNECTION_RESET". All zametalina works in Edge and is taken with the curl.

Tried winsock reset, dns flush, put Google DNS servers, nothing helps. We looked at the history of Windows update - found a relatively fresh update KB3211320 installed around the same time, the problems started.

Did someone with such? Is there a solution? It is not a conspiracy if it's drag and drop users on the Edge?
August 19th 19 at 23:19
2 answers
August 19th 19 at 23:21
Solution
It seems that the problem is caused by the provider. As soon as I switched to a VPN everything was back to normal.
Switching to different vnp does not help to solve the problem ERR_CONNECTION_RESET for some sites.
And other "gromnik" browser websites are opened.

For example www.jobs.bg without https the site opens (runs a redirect to https) and https get ERR_CONNECTION_RESET in chrome.

Even the physical change did not help... - Elsie commented on August 19th 19 at 23:24
August 19th 19 at 23:23
to carry chrome. clean configs cookies and vyakuyu deposits of settings. to put again. profit!

Find more questions by tags Microsoft EdgeGoogle ChromeWindows