How to update the dependent plugin?

Installed through NPM plugin stylefmt that their dependency comes with a plug-stylelint old version of (7.10.1). How do I update the dependent plugin to the current version (9.2.1) automatically?
June 5th 19 at 21:05
1 answer
June 5th 19 at 21:07
Solution
Module stylefmt quite reasonably may require your dependencies in concretos version, in order to avoid breakdowns
If You need a dependent module (stylelint) - install it separately, so You will have the current version, and module stylefmt the version he needs
Stylelint already installed separately, but the situation is slightly different. Stylefmt uses a configuration file stylelint'as well, but since that was updated, there were new settings that stylefmt not understand. So you have to update and nested stylelint for stylefmt. The problem is described here.
P. S. There is a fork of the repository stylefmt in which all the packages of this plugin updated, but I would not want to copy everything manually. - ben_Quitzon3 commented on June 5th 19 at 21:10

Find more questions by tags npm