Why can't I change the permissions on the guest machine in the virtualbox environment?

Set up a development environment using Vagrant inside virtualbox and have encountered a problem to change permissions from the assets folder. Yii2 requires write permissions in the folder, but all attempts to change them were not successful. The chmod command is not properly working. Enter exactly correct, errors in the terminal does not occur. But write not appear.
Host machine macos High Sierra 10.13.4
Guest machine Ubuntu 16.04
What could be the problem?
P. S. law and failed to change, but it solved the problem starting apache from the user vagrant.
Discussion of similar issue here: https://github.com/puphpet/puphpet/issues/138
June 5th 19 at 21:51
1 answer
June 5th 19 at 21:53
I mean given the right Guest user in the Guest group permissions to write to the folder or just did chmod 766? To search in the folder the necessary rights for another performance - and then the file search will not be performed. And Yii2 should like from www to run, not from the guest.
on the guest machine of only two user www-data and vagrant.
The server is running under www-data and has no write permission on the above folder.
I turn root access (aka vagrant) and try to set permissions 777 on the right folder, so Apache would work fine. The command runs, but not the right change. - alexandre_Hagen commented on June 5th 19 at 21:56
root != vagrant. put mc - it beginners much easier. Folder the from -r to specify that all subdirectories of the past. - Saul78 commented on June 5th 19 at 21:59
the vagrant user has superuser rights. Well it is fine, only when the rights change. In my case this is not happening. Also tried the chown command on the folder, no result. - alexandre_Hagen commented on June 5th 19 at 22:02
Folder local to VB or with a ball machine? - Saul78 commented on June 5th 19 at 22:05
on the host machine, the folder /Users/me/Sites/y2/project
is the folder
/var/www/project
on the guest machine. - alexandre_Hagen commented on June 5th 19 at 22:08
Clearly you move the folder on the VM and tmapi in the host system. I have Parallels, I had forgotten about this problem. - Saul78 commented on June 5th 19 at 22:11
interesting point is that the law still change, but the full law can not put.
5afdcd212aa15141821299.png - alexandre_Hagen commented on June 5th 19 at 22:14
So not using vagrant change. - Saul78 commented on June 5th 19 at 22:17

Find more questions by tags UbuntuVagrantmacOSVirtualBox