How to repair switch languages after uninstalling kubuntu-desktop in unity?

What time worked under KDE kubuntu-desktop (plasma)
Re-installed ubuntu-desktop(unity)
Alt+Shift doesn't switch languages. No works (Super+Space too)
Even in gconf-editor set.
Only works in GNOME3.
What I want unity, but the switcher is not working. Even when the cursor click on the layout indicator and change.
Completely demolished all (*-desktop, lightdm, ibus and something else(dpkg --purge))
Please help
September 18th 19 at 23:42
2 answers
September 18th 19 at 23:44
Solution
Well, there is gnome-settings-daemon is keyboard, or unity-settings-daemon in newer versions, although it is a fork of unity and the essence is the same.
Do you have that any of this is?
Yes there is
gnome-settings-daemon
libunity-settings-daemon1
unity-settings-daemon - conner.Reichert commented on September 18th 19 at 23:47
: How about go to the terminal instead of a graphical environment, to fully tear down unity and then put ubuntu-desktop to return to the place all that should be there? Or if the latter is not - to put it in the dependencies will pull what you need. - Bennett.Satterfield28 commented on September 18th 19 at 23:50
: removed all the graphics down to xorg. Installed it again, nothing helped.
I'll try to create a new user. Maybe it's some settings ~/ - conner.Reichert commented on September 18th 19 at 23:53
September 18th 19 at 23:46
Also, as an alternative, you can use xkb and stick it in the autostart.
setxkbmap -layout [languages] -option [key and optional settings]
For example:
-switching on Ctrl and Shift
setxkbmap -layout 'us,ru' -option 'grp:ctrl_shift_toggle'

-switch to Alt and Shift
setxkbmap -layout 'us,ru' -option 'grp:alt_shift_toggle'

-switch on Caps Look with the use of the indicator Caps Look for display switching
setxkbmap -layout 'us,ru' -option 'grp:caps_toggle,grp_led:caps'

Find more questions by tags UbuntuKDELinuxUnity Game Engine