Why file watcher in webstorm throws an error when you add the @import for compass?

Welcome.

Using webstorm 8 to Mac Os X 10.10.

Added file watcher for sass files. Everything works fine, but only until, until you do @import compass/css3. When you add import get error

File to import not found or unreadable: compass/css3


If you open the project using the terminal and do sudo compass watch it works.

PS Tried to open webstorm c sudo rights ( sudo /Applications/WebStorm.app/Contents/MacOS/webide ). It did not help.
September 19th 19 at 12:23
1 answer
September 19th 19 at 12:25
In the project (file->languages&frameworks->compass) connected to it?
d27968accb824a61a48e7ced3b63e704.jpg
The conductor of the project "External Libraries" are?
76643e071e30473495455279b2319296.jpg
thank you for your response. The issue is already decided. By default, webstorm suggests adding watcher for compass and sass files. As a result, the sass watcher "interrupts" compass watcher. After removal of the sass watcher it worked. - fermin_Gibson97 commented on September 19th 19 at 12:28

Find more questions by tags IntelliJ IDEAWebStormJetBrainsSass