Can't lift Rails app on digitalocean (ubuntu12.04x64)?

Hello.
I'm having a problem with the VPS on ubuntu 12.04. That's what I did:
git clone the application
bundle install
to install all gems, even sqlite3
rake db:migrate

after the command rails server the server starts, everything is fine without errors. but when I got on http://ip:3000 see
We're sorry, but something went wrong.

If you are the application owner check the logs for more information.

in the logs here is what
Started GET "/" for "IP" at "time"
ActiveRecord::SchemaMigration Load (0.2 ms) SELECT "schema migration". * FROM "schema migration"

and nothing more.
did the same on his car on Archlinux, everything works. What's the problem??
September 26th 19 at 11:26
3 answers
September 26th 19 at 11:28
Solution
The database it's set up?
Well, database is not present, rake db:migrate I did. I've just done all too well in my car, everything works. But on digital ocean does not work. - Darren15 commented on September 26th 19 at 11:31
September 26th 19 at 11:30
Solution
What if in the console log?
after rails server, when you try to visit the site this is what appears in the console Started GET "/" for "IP" at "time"
ActiveRecord::SchemaMigration Load (0.2 ms) SELECT "schema migration". * FROM "schema migration" - Darren15 commented on September 26th 19 at 11:33
Console. bundle exec rails console - Darren15 commented on September 26th 19 at 11:36
Because it is the expression that you cite, does not seem to make a mistake.
If you have worked as a web server, perhaps an error page would be printed regardless of the ruby, and the reason was the logs of the web server.

But if you're perverted and launch built-in... you need to find the error. - katrina.Medhurst77 commented on September 26th 19 at 11:39
I just needed to test, deploy was about then, but when even that doesn't work, weird. - katrina.Medhurst77 commented on September 26th 19 at 11:42
so in the console?
Well, as it virtualtech... are You sure that port 3000 is open, that the user from which you run, have rights, etc.? - Darren15 commented on September 26th 19 at 11:45
it worked on 14.04 - katrina.Medhurst77 commented on September 26th 19 at 11:48
September 26th 19 at 11:32
Solution
the problem was solved by the creation of new droplet to DO with ubuntu14.04, it worked immediately!

Find more questions by tags DigitalOceanRubyRuby on RailsUbuntu Server