How to configure samba on debian 7?

The bottom line:
You have a server with a screw 250 hectar and 4.5 tb RAID6. It raised the Debian 7, samba 3.6.6 installed, read the sea of manuals on setting up, on high. what happened. this through Windows Explorer by ip address to log on to the server and see the shared folder, which can not get.
452e5bdce89843caa85fc0bd2e388650.PNG
[global]

workgroup = WORKGROUP
netbios name = ftp
server string = %h server
dns proxy = no

log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d

security = share
encrypt passwords = true
passdb backend = tdbsam

obey pam restrictions = no

unix password sync = no
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes

[homes]
comment = Home Directories
browseable = no
read only = no
create mask = 0700
directory mask = 0700
valid users = %S

[MediaContent]
path = /media/ftp-data/MediaContent
readonly = yes
writable = yes
guest ok = yes 
create mask = 777 
directory mask = 777

This is the contents of smb.conf
It is believed that this is due to poor synchronization of accounts and passwords.
And anyway, explain to me dark. how to avidity accounts for samba.
September 26th 19 at 11:48
6 answers
September 26th 19 at 11:50
Solution
Here is my config, maybe that you will need.
[Global] 
 workgroup = VLG SERVER34
 netbios name = Server
 server string = 
 security = share
 browseable = Yes

[all]
 path = "/"
 force user = root
 force group = users
 read only = no
 create mask = 0777
 direcrory mask = 0777
 guest ok = Yes

[file]
 path = "/home/server/"
 force user = server
 force group = users
 read only = no
 create mask = 0777
 direcrory mask = 0777
 guest ok = Yes

[SERVERWEB]
 path = "/media/serverweb/"
 force user = root
 force group = users
 read only = no
 create mask = 0777
 direcrory mask = 0777
 guest ok = Yes

[HOSTING]
 path = "/media/hosting/"
 force user = server
 force group = users
 read only = no
 create mask = 0777
 direcrory mask = 0777
 guest ok = Yes

[Log]
 path = "/var/log/"
 force user = root
 force group = users
 read only = no
 create mask = 0777
 direcrory mask = 0777
 guest ok = Yes

[WWW]
 path = "/media/serverweb/www/webserver/data/"
 force user = webserver
 force group = webserver
 read only = no
 create mask = 0777
 direcrory mask = 0777
 guest ok = Yes
September 26th 19 at 11:52
September 26th 19 at 11:54
User need to add.
smbpasswd-a user
September 26th 19 at 11:56
September 26th 19 at 11:58
readonly = yes
writable = yes

You then do not bother?
Check your config with the commandtestparm

Try to do this config:
[global]
 workgroup = MYGROUP
 server string = Samba Server Version %v

 log file = /var/log/samba/log.%m
 max log size = 50

 security = user
 passdb backend = tdbsam
 map to guest = Bad User

 load printers = yes
 cups options = raw

[share]
 comment = Public Stuff
 path = /media/ftp-data/MediaContent
 public = yes
 writable = yes
 printable = no
 guest ok = yes
September 26th 19 at 12:00
the Samba user has read rights to /media/ftp-data/MediaContent

Find more questions by tags DebianLinuxSamba