1C and Microsoft SQL server 2008 r2 sp1 via Shared Memory

Good afternoon, colleagues.

Help to make 1C and Microsoft SQL server 2008 r2 sp1 via Shared Memory. The source data is the following: Server: Windows Server 2008 R2 1C platform 8,2,18,102 SQL Server 2008 r2 sp1

They work naturally on a single server. Did the settings as described in this article: http://selestajob.ru/article/index.php?ELEMENT_ID=111583

Server Profiler shows that the connection is only TCP. To completely disable the TCP communication is impossible, since on this server the spinning base other services.

Thank you.

October 3rd 19 at 02:14
4 answers
October 3rd 19 at 02:16
Solution

In General, he asked a question, he will answer, maybe useful to someone.

I have Shared memory gained after I specified in the settings information database in 1C the path to the database in the format server name\instance when I pointed to localhost, or just the name of the server Shared memory was not working.

PS TCP disable was not necessary.

Similar problem. Turns on Shared memory. Now in connection settings localhost. Prescribed format server name\instance (i.e. server1c\MSSQLSERVER) 1S not connected. - pearl_Web commented on October 3rd 19 at 02:19
October 3rd 19 at 02:18

Server 1C will not work on Shared Memory, if available TCP connection. At least I didn't succeed.

Install a separate instance of the SQL server and disable it TCP, and 1C-server "dump" for this new instance.

Other base and let cool on the primary instance.

October 3rd 19 at 02:20

Today I tried to disable the TCP experiment, leaving only the Shared Memory 1C does not start, gives this error: 9512e1968269be58b7ba2485f008e60f.png

Google wasn't much help, can someone faced?

October 3rd 19 at 02:22
Encountered, include the namespace in the SQL Server configuration Manager

01058c2acd5bf3f53aaa6f430d9091b9.png

Find more questions by tags SQL1C