Not getting emails sent with JavaMailSender with amazon EC2 to google mail (aliases)

Hello!
Never did web, but then I had to work. The problem is following — I have the dev (ubuntu) on amazon EC2 (yet without the domain name), there's a website (java + JSP), the apache server that proxies all tomcat'have mail server Postfix. Java send mail successfully sent and reaches the addressee, but to a specific address (an alias) the email is not coming. Not even to a particular address and for every alias with a specific domain name. The people (which mail does not reach) have mail on google, just with a domain name (more details can not describe. because you do not understand this, but I think webmasters will understand what I mean).
I think code is not needed, but just in case — send mail like this:

 MimeMessagePreparator preparator = new MimeMessagePreparator() {
@Override
 public void prepare(MimeMessage mimeMessage) throws Exception {
 MimeMessageHelper message = new MimeMessageHelper(mimeMessage,true,"UTF-8");
message.setFrom(emailFrom);
message.setTo(emailManager);
message.setSubject(emailToManagerSubject);

 Map<string,object> model = new HashMap<string, object>();
 // fill model

 String text = VelocityEngineUtils.mergeTemplateIntoString(
velocityEngine,
"email_tpl.vm",
"utf-8",
model
);
 message.setText(text, true);
}
};

try
{
this.mailSender.send(preparator);
}
 catch (MailException ex)
{
 logger.error("some text");
}
}
</string></string,object>

where mailSender and velocityEngine declared here
@Autowired
 JavaMailSender mailSender;

@Autowired
 VelocityEngine velocityEngine;

Yes, even — to any other email address (not an alias) with the same domain name letter reach, the problem is with aliases. On the alias with a different domain name (tried to create a so-called "group" in your gmail account) also reach. In Postfix'and logs (/var/log/mail.log) everything is OK, mail is sent without error but the receiver argues that there are no letters.

I don't know where to dig, maybe somebody have any ideas?

update
When sending with sendmail emails reach.
October 3rd 19 at 04:11
1 answer
October 3rd 19 at 04:13
You watched the responses of the post demons of Google? Maybe they think your mail is unsafe or spam. Perhaps not condescend to answer. When sending my emails to such aliases Google a particular domain, too, at first there were no answers, as I recall. Then one day I found:
<<< 552-5.7.0 This message was blocked because its content presents a potential
<<< 552-5.7.0 security issue. Please visit support.google.com/mail/bin/answe
<<< 552-5.7.0 r.py?answer=6590 to review our message content and attachment content
<<< 552 5.7.0 guidelines. i8si322258lam.42 — gsmtp
554 5.0.0 Service unavailable
Thanks, can you tell me where to find these answers? In the logs I've seen. - roy.Stark72 commented on October 3rd 19 at 04:16
This letter came from a robot — I quoted part of the message that explains the reason for blocking (all e-mails). - alba_Purdy commented on October 3rd 19 at 04:19
And where comes? On the sender address? Just my sender is not an existing address support@domen.ru. - roy.Stark72 commented on October 3rd 19 at 04:22
Yes, of course, on the sender. - alba_Purdy commented on October 3rd 19 at 04:25
Thanks, the most important thing forgot to ask — are You somehow solved this problem? - roy.Stark72 commented on October 3rd 19 at 04:28

Find more questions by tags Amazon Web ServicesGoogleJavaPostfix