Samsung galaxy s2 android 4.1.2, not sent SMS messages

Actually a subject.
A brief history of such. A long time passed with official ICS on Board, the phone worked fine. No problems with SMS were observed. After updating the firmware again on the official 4.2.1 phone after download can send one SMS, which regularly comes to the recipient in the SMS status somehow says "sent". After that, no SMS from the phone cannot be sent. Everyone hangs a status of "sent".
Tell me, please, what could be the problem.
October 3rd 19 at 04:21
4 answers
October 3rd 19 at 04:23
Solution
You could try to just wipe dalvik cache. or clear cache of the app.
Helped) Thanks! - elnora_Cassin70 commented on October 3rd 19 at 04:26
October 3rd 19 at 04:25
What they say about this on 4pda?
On 4pda couldn't find one but online a similar request suggest resetting to factory settings and formatting the memory card. Not the fact that will help so I would like to know whether there was at somebody such and if Yes how to solved the problem. - elnora_Cassin70 commented on October 3rd 19 at 04:28
Wipe data to get started, try...
If it does not help then format the card and install the firmware from scratch... - elnora_Cassin70 commented on October 3rd 19 at 04:31
Sorry for oftop. A little off topic, but a purely logical mind can not understand that the card is formatted may affect the SMS. There's a thread of an explanation? Why not just map to vinati? Or a piece of OSes is on the map? - Asha35 commented on October 3rd 19 at 04:34
In the standard settings app SMS the SMS center number check? And in "creation mode" is "free"? - Maxine_Turner commented on October 3rd 19 at 04:37
SMS centre is spelled correctly, the first thing checked. About the create mode I do not understand is the input mode which? Where encoding is selected? If Yes, then I automatically is no option "free" no. - efrain_Hartmann33 commented on October 3rd 19 at 04:40
October 3rd 19 at 04:27
I had this on Xperia x8, I can not remember as cured, SMS center here there is nothing, there is something with the system itself. I had this on AOSP firmware, then rolled out some fix and all was well.
So I suggest a hard reset to do, if not help, then full flashing.
Clear. Most likely will have to do so. - elnora_Cassin70 commented on October 3rd 19 at 04:30
October 3rd 19 at 04:29
You need to go to Messages - Options - Settings - input Mode - set the mark for "Unicode".

Find more questions by tags AndroidSamsung Galaxy