IE9 unexpected behaviour when typing Cyrillic characters in any field to enter?

Today suddenly faced with a strange reaction on IE9 the text you type Cyrillic in any field for entering characters. In particular, if you open in ie9 google.ru and try to enter a search string phrase "Converter DAT" instead of Cyrillic letters appears the following:

dbba7be2e15b54e22226a1e5c2157408.png


If you enter non-English layouts (for example, anything in English), then everything is correct.


OS: Windows 7, English. All the updates, in particular those covering holes in the security system of the OS installed.


The version of the IE browser, in which there is described the action: 9.0.8112.16421.


Punto Switcher is there, but a glitch is observed when PS is enabled and when disabled.


In all other browsers (Chrome, Opera, Safari, Firefox, etc.) this is not observed. Moreover, even in IE10 platform preview, which is also installed in the system, the Cyrillic alphabet everywhere is entered correctly.


What do you think could be causing this unusual behavior in IE9?


UPD: reboot, reopen IE9. No effect: the symbols continue to be incorrect.
October 8th 19 at 00:37
2 answers
October 8th 19 at 00:39
Solution
If anyone finds this question via search.
In my case the problem was because the add-in Logitech SetPoint. It may be due to other add-ins (link)
And this, by the way, idea! I have just on PC mouse Logitech m500 used. Tonight I'll try to check out how to lead the donkey with a disabled mouse add-on. - Caterina_Fadel commented on October 8th 19 at 00:42
Closed the app Logitek from the system tray and shut down its service executables Manager. No matter how well kryakozyabry still displayed (instead of ie9 and now ie10 is, but the behavior Cyrillic not changed).
Apparently, it's some other addon someone.
If you subsequently manage to find the enemy, be sure to accomplish your goal here. - Caterina_Fadel commented on October 8th 19 at 00:45
Still, Yes, it is. Went to the donkey in the properties, in the "Manage add-ons" I saw there Logitech Flow Scroll. Moved him to the Disabled mode (off), and everything immediately worked as it should.

zhindetz, thank you! - Caterina_Fadel commented on October 8th 19 at 00:48
October 8th 19 at 00:41
Perhaps You have something of Cyrillic is not installed.
It seems to be everything you need there. Again, all other browsers works correctly.
Though earlier all was good in terms of display, this situation was only found this afternoon. - Caterina_Fadel commented on October 8th 19 at 00:44

Find more questions by tags BrowsersInternet ExplorerCyrillic