Terrible brakes at compile time in Visual Studio?

Good day!


Lately (possibly after some updates) Visual Studio has become very hard to load the computer at compile time. Very much is "stuttering" music Core i7 considering the fact that cl.exe (the C++ compiler) is executed with low priority (base priority applications can be configured in the registry) is just nonsense. After some time trying to understand what is going on with the computer, I noticed that during compilation time of the kernel ("Kernel Time") in task Manager reaches 90+% of the total time the CPU (which probably leads to bugs). Stack analysis shows that the time spent on synchronization (the process is almost constantly hanging inside "ntoskrnl.exe!KeAcquireSpinLockAtDpcLevel+0x682"). Treated these symptoms are a reboot of the computer after some time all is well (Studio starts up, compiles the processor is loaded in a normal mode, i.e. spending in the core 10-15% of the time).


I would like to know if there is a problem anyone else has and what to do with it.

To reinstall Studio/Windows, please do not offer.
October 8th 19 at 00:46
6 answers
October 8th 19 at 00:48
Maybe something with the drivers or system services? simple process-colognes unlikely to hang the kernel. Also, make sure you have enough memory and will not go if the PC is in the swap. Also, try procmon, let's see what happens in the system. You can also try API Monitor showing system calls. Loopb process explorer and API monitor I recommend, if you want elaboration.

To have music stutter under Windows — the computer very much it should be tortured, this almost never happens.
With memory swap, etc. all good. The problem is that despite the low priority compilation, the compiler manages to boot the system (due to a strange glitch that causes 90% of the time of transmission to the compiler in the kernel). The idea with procmon thanks, somehow I forgot about it completely. - deion_Howe commented on October 8th 19 at 00:51
October 8th 19 at 00:50
I don't know about VS 2010 and 11 beta at all a computer puts on the shoulder, I realized some process moves to the priority of real-time and loads percents on 100%, the computer is hung up on is dead, roughly, what it does Intellisence, because occasionally occurs before you are prompted. To understand especially did not become, and was removed and returned to VS2010. And VS2010 it seems to work fine.
Well, You're a special case, I have VS2011 on two machines and all is well. - deion_Howe commented on October 8th 19 at 00:53
The priorities here is not exactly what I was checking hands at the thread level. The priority is low. - xander_Kozey commented on October 8th 19 at 00:56
October 8th 19 at 00:52
And with the HDD you have no problem by any chance?
Was already changed, already present. Drive in locations hang is not very busy. Although, maybe the driver on the RAID? Try to check this option, thanks... - deion_Howe commented on October 8th 19 at 00:55
October 8th 19 at 00:54
Once faced with a similar problem. After a long guglani found tip — to remove all breakpoint using Debug -> Delete All BreakPoints. It helped me, maybe will solve your problem.
October 8th 19 at 00:56
I remember, was hovering due to IntelliTrace. Disabled — debug was smarter than to go, maybe you have this as something to do.
Disabled for a long time — she is still in With++ is not working. I have tried to disable IntelliSence, but it is crap without the resource tree doesn't work :( - deion_Howe commented on October 8th 19 at 00:59
October 8th 19 at 00:58
ntoskrnl.exe!KeAcquireSpinLockAtDpcLevel

Well, it's certainly NOT Visual Studio ITSELF. Supposedly some very smart filter/minifilter (possibly antivirus: like he needed a CPU to test Signa). Try to collect the profile trace with stacks and see who are the most spinlocks captures.
> to check Signa
... to verify the signatures, and all otorola Studio - deion_Howe commented on October 8th 19 at 01:01

Find more questions by tags C++Visual Studio