HSRP on two sides of the tunnel?

I want to combine 2 office by using gre tunnel between cisco routers. In both offices the provider gives you a /30, i.e. I is given in the first office 1.2.3.6 1.2.3.5 gateway, with the gateway 2.2.3.6 2.2.3.5 in the second. I want to put both sides of 2 Cisco 881, which address 1.2.3.6 and 2.2.3.6 reserved by using HSRP. In the first office on the interfaces hang addresses: 1.2.3.1, 1.2.3.2, 1.2.3.6 HSRP saying in General. In the second, respectively: 2.2.3.1, 2.2.3.2, in HSRP 2.2.3.6 — General. In this configuration, the cat is to initiate a connection with invalid provider address 1.2.3.1(2.2.3.1) and don't see each other, while happily answering HSRP shny address if the request comes from any other host on the Internet.

cisco1


interface FastEthernet4

ip address 1.2.3.1 255.255.255.248

standby 20 ip 1.2.3.6


interface Tunnel10

ip unnumbered FastEthernet4

tunnel source 1.2.3.6

tunnel destination 2.2.3.6


interface FastEthernet4

255.255.255.248 ip address 2.2.3.1

standby 20 ip 2.2.3.6


interface Tunnel10

ip unnumbered FastEthernet4

tunnel source 2.2.3.6

tunnel destination 1.2.3.6


How can this be overcome?
October 8th 19 at 00:51
1 answer
October 8th 19 at 00:53
Solution
Well and itself I will answer. The problem was not that the tunnel was not working and that inside of it is not running traffic. all was resolved by replacing ip unnumbered FastEthernet4 at ip address 192.168.1.1 255.255.255.252 on the one hand, and ip address 192.168.1.2 255.255.255.252 on the other
and now in your message hit that this is the #solution
thank you, by the way, for the answer) - carolanne.Bashirian89 commented on October 8th 19 at 00:56

Find more questions by tags GRETunnelingCisco