KVM and empty (sparse) files

Create a file "hard disk" by using this command:
qemu-img create-o preallocation=metadata -f qcow2 test.img 20G
The file is small in size. But after splitting the drive and installing file system immediately begins to weigh 20Gb
How to make sure that the file gradually grew up and played from 20Gb?

UPD. All figured out. Everything is working fine. Just didn't know what you need to view at actual size use ls-s
October 8th 19 at 01:06
1 answer
October 8th 19 at 01:08
What is your Linux? metadata preallocation on QCOW2 is not always supported.

help.ubuntu.ru/wiki/kvm — Guest need to be aware of this final specified size, however, during installation it can see the real file size. Of course, be installed on hard drive size 200 KB she refuses. Bug not specific to Ubuntu, is manifested in RHEL, at least.
Linux — Ubuntu 10.04. Without this option preallocation=metadata system did not put a like just because of this bug. After splitting the file disk became 20Gb. - Dominique36 commented on October 8th 19 at 01:11

Find more questions by tags KVMSystem administrationLinuxFile systems