Install Blitz Template for php 5.3||5.4?

Hi, Habr!

The need arose to install blitz on a new car.


when you make throws
/root/blitz-0.6.10/blitz.c:30:23: error: safe_mode.h: No such file or directory

/root/blitz-0.6.10/blitz.c: In function 'blitz_exec_wrapper':

/root/blitz-0.6.10/blitz.c:1732: warning: passing argument 3 of 'php_escape_html_entities' from incompatible pointer type

/usr/include/php5/ext/standard/html.h:57: note: expected 'size_t *' but argument is of type 'int *'

/root/blitz-0.6.10/blitz.c: At top level:

/root/blitz-0.6.10/blitz.c:4041: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'blitz_functions'

/root/blitz-0.6.10/blitz.c: In function 'zm_startup_blitz':

/root/blitz-0.6.10/blitz.c:4083: error: 'blitz_functions' undeclared (first use in this function)

/root/blitz-0.6.10/blitz.c:4083: error: (Each undeclared identifier is reported only once

/root/blitz-0.6.10/blitz.c:4083: error: for each function it appears in.)


have
php-v

PHP 5.4.0-2 (cli) (built: Mar 5 2012 12:52:15)

Copyright © 1997-2012 The PHP Group

Zend Engine v2.4.0, Copyright © 1998-2012 Zend Technologies

uname-a

Synclexpro Linux 2.6.32-5-amd64 #1 SMP Mon Jan 16 16:22:28 UTC 2012 x86_64 GNU/Linux


Curable?

There is an assumption that the error due to the mismatch version of php.
October 8th 19 at 01:41
2 answers
October 8th 19 at 01:43
If swung archive with Blitz — try to copy directly from the repository.
If in this case too do not gather — most likely the extension is not adapted to work with 5.4. Post about the problem in bugtracker...
gather hope through phpize -> configure -> make and not make in the past phpize -> configure to 5.3 - Adrien.Tremblay commented on October 8th 19 at 01:46
yeah, collect so.
sorry, "copy directly" — pour from a turnip? not found on the website the instructions on the repository - Madison.Kreig commented on October 8th 19 at 01:49
Hmm, then it is most likely not finished the support 5.4.
Try that, if the Unstable version, maybe there is a compatibility corrected.
Yet I do decided to sit on 5.3 too many extensions is not going under 5.4 - Adrien.Tremblay commented on October 8th 19 at 01:52
tried. the same error.
The admins gave the opener, but he said that with another API than PHP under which he tcompile will not work.
You may have to do the download version. What is not desirable, because to upgrade sooner or later. - Madison.Kreig commented on October 8th 19 at 01:55
October 8th 19 at 01:45
I will leave it here for others
php -m | grep "bli"
PHP Warning: PHP Startup: blitz: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20100525

goes the search for the magic potion
Version 0.6.8 was working in production at 5.3. Now 0.8.1 is running — all going under and under 5.3 and 5.4. If something still does not work, please mail me — alexey d0t rybak at gmail d0t com. - Adrien.Tremblay commented on October 8th 19 at 01:48

Find more questions by tags LinuxPHP