Do not login to FTP server pure-ftpd, what to do?

Set up here for this example.


Does not connect, try using Explorer.exe and phpStorm. Error: "connection rejected".


Thanks for the tip with the console, like that the sleepy head had not thought of. On the machine where ftp did I do ftp localhost, and the connection is successful.

When I try from another machine, connect phpStorm'Ohm, get the "connection rejected", and if after explorer.exe — he behaves as if the user's password is incorrect.


On the machine with the ftp is Debian 6.
October 8th 19 at 01:42
2 answers
October 8th 19 at 01:44
Try to go to FTP from the console:
ftp localhost
Trying ::1...
Trying 127.0.0.1...
Connected to localhost
220---------- Welcome to Pure-FTPd [privsep] [TLS] — 220-You are user 1 of 50 allowed
220-Local time 09:12. Server port: 21.
220 You will be disconnected after 15 minutes of inactivity.
Name (localhost:c-n1x):
331 to enter as c-n1x requires a password
Password:
230-your Bandwidth for you limited
230-User c-n1x allow a group access to: wheel 1001
230-You must respect a ratio of 1:10 (UL/DL)
230-OK. Current root directory /
Of 230-1 files used (0%) — authorized: 10000 files
230 0 KB used (0%) — authorized: 102400 KB
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pwd
Remote directory: /
ftp> quit
221-good for you. You uploaded 0 and downloaded 0 Kbytes.
221 Disconnecting.
If it knows everything should be OK, if otherwise, then lay out here, we'll see. - Jeffrey.Jon commented on October 8th 19 at 01:47
Of windows went like this:

C:\Users\Jakeroid>ftp 192.168.56.2
Connected to 192.168.56.2.
425 Sorry, invalid address given
Connection closed by remote host. - Neha11 commented on October 8th 19 at 01:50
add -H /dont resolve/ option to your start line

OLD:

/usr/local/sbin/pure-ftpd -o -E-l puredb:/etc/pureftpd.pdb -l unix -p 40000:50000 &
NEW:
/usr/local/sbin/pure-ftpd -o -E-l puredb:/etc/pureftpd.pdb -l unix -p 40000:50000 -H & - Dewayne.Russel73 commented on October 8th 19 at 01:53
I have Debian, how to change the startup parameters? - Neha11 commented on October 8th 19 at 01:56
Tinkering with /etc/init.d/pure-ftpd — see what he does with the team (re)start - Dewayne.Russel73 commented on October 8th 19 at 01:59
Thanks, I'll try! - Neha11 commented on October 8th 19 at 02:02
Indeed, the option works! - Neha11 commented on October 8th 19 at 02:05
Thank you! - Neha11 commented on October 8th 19 at 02:08
And to add the option and it did not work: (only if run manually. - Neha11 commented on October 8th 19 at 02:11
Added, had to do echo "yes" > /etc/pro-ftpd/conf/DontResolve. - Neha11 commented on October 8th 19 at 02:14
That is /etc/pure-ftpd... - Neha11 commented on October 8th 19 at 02:17
October 8th 19 at 01:46
To answer your question answer the following
What say the Logs pure-ftpd?
Says native win ftp client?
Open whether ports on the FTP server?

Find more questions by tags Pure-FTPd* nix-like systemsFTP