USB HDD ExFat partition became read only

Again, something happened with the USB HDD (Toshiba 320GB). Like while writing to the partition ExFAT became Reid onli ie not deleted the files with him and didn't sign up, Windows suggested scanning errors, but it hung on 0%, with the first partition FAT32 worked fine.

upd: has Perevodom in the comp (137ГБ and offer to format it after mounting to dev with Ubuntu), now back to the initial state: reed onli.

DMDE
October 8th 19 at 01:51
5 answers
October 8th 19 at 01:53
Solution
Fixed by removing the flag that makes ExFat partition reed onli (replaced the 02 at offset 6a 00), forum.ixbt.com/topic.cgi?id=11:43421-63#1880. While it seems to work.
the link was cut - randal.Bergnaum78 commented on October 8th 19 at 01:56
October 8th 19 at 01:55
And on another computer also this behavior?
October 8th 19 at 01:57
most likely you fell off the file table
Try some some antrocom to scan
October 8th 19 at 01:59
Try www.cgsecurity.org/wiki/TestDisk as-that very much helped to regain the lost FAT
He like ExFat is not friendly, once tried unsuccessfully. - randal.Bergnaum78 commented on October 8th 19 at 02:02
Written supports, and cengage seen that in versions 6.11 and 6.12 was better support exFat. To try it never hurts :) - randal.Bergnaum78 commented on October 8th 19 at 02:05
October 8th 19 at 02:01
Anyway, in this situation it is better to copy the data somewhere, format, and pour back. Heart will be calm.

Find more questions by tags exFATToshibaHard disksdata recoveryIron