The problem with the boot with raid

The background
I lacked the speed of the disk on the computer and it was decided to make raid 0+1 of 4 disks. The motherboard supports software RAID, the drives were purchased, configured, everything worked fine.
Then I decided to try to boot from disk ubuntu 9.04 and see if this linux raid as a single disk. The miracle did not happen, linux disk did not see. Well, okay, I think. Reboot back into Windows and while booting I get a message that all 4 discs now "Offline member".

workaround
Google search gave this a cunning decision: you need to load ubuntu live cd, install dmraid package and restart the computer. If you do everything right, all of the drives at boot marked "online member", the system starts and runs.

Question
All works only until the computer is turned off. As soon as the computer shuts down, the entire procedure of startup disk of Ubuntu need to be repeated. Reboot it can and can not be shut down.

That's the question: what the heck is that? How to fix it?
October 8th 19 at 02:33
2 answers
October 8th 19 at 02:35
there is little information.
0. The host operating system under which the RAID was cool and everything worked?
1. This software(originally configured operating system) or hardware RAID?
2. If the hardware, the battery on the motherboard/controller looked?

The first thing that comes to mind is to try to go into the settings of the RAID and force the drives online.
0. Win2003 (don't think it fundamentally drives off during POST check).
1. Is the RAID built into the motherboard.
2. No, the battery pull did not try (battery is only one — the one on the motherboard).

Yes, in settings you can go, but it warns that when handling all the data can be lost. I have experience with raids is not present, so I was afraid I'd have to re-configure normally running the server now and start using ubuntu.

The name Mat.the Board will not be able to write in the next 3 weeks. - Santa_Marvin66 commented on October 8th 19 at 02:38
It's good that it warns about data loss. But if you go into the settings of the RAID, nothing terrible will happen. So feel free to go into settings and see that as a Yes. Are there any messages, warnings, and so on.

But in the make and model of the motherboard in the Studio! Will download the manuals and see what the settings of the RAID. - mattie_Howe commented on October 8th 19 at 02:41
October 8th 19 at 02:37
First, Yes, join queries — what motherboard?

After installing dmraid in the live CD of Ubuntu begins to see the drives? (To start.) If Yes, then you can at least save the data and the system (clear the way).

What is seen in the BIOS before rebooting with Ubuntu (well, as it is combined with offline member)? What is clear after reboot?

btw, 9.04 is a very ancient system, it is realistic that the old mdadm which is not able, and in the new, for example, may be able to. Look at kernel version: 2.6.32 isn't able, able 3.2. (Dmraid itself is much more ancient than bios support fake raidов in mdraid).
I think I VAZ disturbed. Now came to check what kind of Board and that gives Linux turned off, turned on, all booted without problems. Strange, nothing has changed, sort of. Earlier constantly had people from the live-cd to boot, now called the store Manager, he says that Yes, as long as it works, never by the user from the live-cd did not have to run.

The Board is ICH8R/ICH9R controller, the name of the motherboard, I think it's not important.

I think I poorly described the situation initially. The computer was working as terminal server Win2003, other OSes wasn't there.
Then I was curious how to see Linux raid — launched live CD, started gparted, it showed me 4 single unpartitioned disk (if not mistaken), then I rebooted the computer, hoping to boot into windows. And then I got the message offline member.
Since then windows starts to boot to the live CD, ostanavlivali dmraid and rebooted in Windows. Everything worked, the data was in place, he windows worked like nothing happened. If Windows click restart, the system rebooted and loaded without problems. The problem appear if you turn off the power (either from Windows or off the light), then had to use a live-CD, so the discs were again online member.

Now for me was a surprise that everything is working as it should and the live SD is not needed. - Santa_Marvin66 commented on October 8th 19 at 02:40

Find more questions by tags Client side optimizationRAID